I always get this error [IXP -- Accessing user layer that has not been registered : Interactivity.Loading Screen]

I just started working on my game this morning and all my scripts that had been working just fine weren’t working anymore, they weren’t throwing any errors and I confirmed the logic, and I found that many of the gui elements don’t work anymore. I tried playing my game outside of studio to see if it would work, and as expected it didn’t work but this time it gave me an error.
IXP – Accessing user layer that has not been registered : Interactivity.Loading Screen

Also, it is not just in my game it happens in every other game I visit! It would be nice if someone could tell me what is going on.

1 Like

I do not know exactly what it is, it has started happening in a game that I work on and never used to. The error is not that descriptive, I think it might have been something roblox was updating and never noticed.

Well, it is preventing me from working on my game. Do you think you could file a bug report? I am not high rank enough.

Try whats happening when you copy your whole Game to another Game and publish it there

From what I’ve been able to tell, this is just a weird bug with the roblox client. It only appears to happen outside of studio and all of the times I have encountered it, all GUI’s appear to still be functional.

Can’t say why your GUI has suddenly stopped working, could you describe what exactly the problem is with your scripts?

1 Like

I also had this error but all my UI still worked fine.

Having the same issue as well, started happening today.

I fixed it by respawning the gui instance.


What do you mean exactly? I have the same issue so I’d like to know how you fixed it

I just cut the gui elements and scripts and pasted them lol

1 Like