I can’t make invisible parts cast a shadow

There are a bunch of posts that I’ve read concerning getting a part to cast a shadow while still being invisible. Basically, you insert this script into any part that you want to be invisible:

local part = script.Parent

part.Material = "ForceField"
part.Transparency = (-10^100)

• I’ve tried this as a ServerScript and as a LocalScript and it does’t work.
• I am parenting this to a normal block part and not a MeshPart or a part with SpecialMesh inside.
• I am using the Future Lighting Technology
• I have also tried manually setting the opacity to some huge negative numbers like -7583257957385782656794652965274562
Has this been patched?

Set the transparency to 0.9999.

If the transparency for any material is above 0.7, then it doesn’t cast a shadow. If it is set to 0.7 then it is still too visible.

Try to set your transparency to “-999999999999999999999999999999999999999” or lower and part material to Force Field.

Quite easy, but let it be known that the old trick was indeed patched. You can use an alternative method, though.

  • Set the Material to ForceField.
  • Set the Transparency to 0.74.
  • Set the Reflectance to 1.
  • Set the Color to any dark enough colour; I’d suggest setting it to 113, 113, 133, as it makes it close to invisible.

Let it be known, that it won’t make the part fully transparent, but will make it quite hard to see, and will still have a shadow.

Oh well, that seems like a better answer, it works.

With ForceField and exactly -999999999999999999999999999999999999999 transparency:
Screenshot 2024-04-22 at 5.50.02 PM
Maybe it’s just that I’m using Future Lighting? I will try your method and give you an update

It doesn’t work perfectly but it is very unnoticeable, especially since I’m using the part to be the shadow-caster for a cube-like mesh (for performance) and it kind of blends in.

1 Like

Use the command bar to set it. It wasn’t patched.

workspace.Part.Material = "ForceField"
workspace.Part.Transparency = -10^100

Works on all graphic levels.

The command line doesn’t work for me and the place file is empty:
Screenshot 2024-04-24 at 5.01.10 PM

It’s a model asset. Not a place file.

Right click on workspace and press insert from file and insert it. It’s the exact part from my screenshot.

I’m sorry but it doesn’t work for me when I do “Insert from file”. It’s just a light grey part
Screenshot 2024-04-24 at 6.40.48 PM

wanna publish it to a place or smthn? i think it may be on ur end

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.