I can no longer open Studio by double clicking on the .rbxl file

Almost every new Studio version, the update creates a mess on my windows, losing shortcut associations and I often have to reinstall everything from scratch…
This time now, I can no longer open Studio by double-clicking on a .rbxl file:

How to fix this?

3 Likes

Just select Roblox in that list and it should apply it as the default.

This will only open Studio, but not the associated file as it should be…
And also won’t fix the file association…

1 Like

Right click on that file > Properties > Change opens with > Select Roblox Studio > Press apply

1 Like

Almost there… this fixed the file association and opens Studio when clicking on the .rbxl. But it’s still not opening the file, it stays only the “Recent” menu…

2 Likes

I don’t know why Roblox never gives attention to this mess on every Studio update…
I had already tried solutions 1 and 3 you mentioned but without success.
I wanted to avoid having to reinstall again and again, because reinstalling Studio only fixes part of it, since I have to fix the associations later.
But I realize that I will have to live with this curse forever… This is a shame…
In any case, thanks for the help.

You can search for solutions here: https://en.help.roblox.com/hc/en-us

Or you can contact roblox support here: Support - Roblox

Did you fix it or not yet I am facing same issue

Only reinstalling Studio…


October 2022. Have the same problem, reinstalling did not solve it. This is getting really awkward, as we are talking about a big corporation. One would say they have the financial power to solve a minor issue as this one.

Try doing a full Roblox clean, uninstall ALL Roblox (I use IObit Uninstaller), eliminate any residual files with the term Roblox (I use VoidTools Everything) then do a clean Windows registry and take any trace of Roblox there (I use CCleaner).
After that, install Roblox normally (but NEVER use administrative privileges to run anything on Roblox).

Yeah, try to use your financial power to push Roblox to pay more attention to bug fixes.

1 Like

thanks for the tips ! appreciate it.

1 Like

This has been a recurring problem for a long time.
Again it happened to me.
I was able to fix it by changing the following Windows registry key: HKEY_CURRENT_USER\SOFTWARE\Classes\Applications\RobloxStudioLauncherBeta.exe\shell\open\command
with this value:
"C:\Program Files (x86)\Roblox\Versions\RobloxStudioLauncherBeta.exe" -ide "%1"

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.