I cannot install both roblox and roblox studio

I’ve found the solution to this, what you have to do is go to the shortcut in your desktop, open file location and open the RobloxPlayerLauncher, not the Player, which is this one:


If you don’t have a shortcut in your desktop for whatever reason, you just gotta search in this directory on your PC, which you can search by opening windows explorer and just clicking on the folder directory at the top, which should look something like this


But after you click, you can put a directory. Copy this directory (with your user replacing the red part)


And then find the latest version which you can check by seeing the last modified date of the folders in there by checking their properties, which you should then find the RobloxPlayerLauncher inside.

Hope this helps while they fix this bug.


I can confirm this is happening far too much lately, I’ve barely been able to join a game once without roblox “deleting” itself afterwards.

To anyone not being able to find roblox versions in the localappdata folder look inside here instead:

Roblox instead of installing into… appdata like before it’s now here…

The fix by the way is run “RobloxPlayerLauncher.exe” inside of that folder, NOT playerinstaller, playerLAUNCHER only, that should fix it for you.


Also if it helps the developers this is what the installer creates in C/ProgramFiles(x86)/Roblox/Versions after this installer is ran


Prior to using this method aka, using the installer downloaded from roblox these files aren’t created anywhere and the real installer just closes instead, “RobloxPlayerLauncher” seems to install roblox better than the “RobloxPlayerInstaller” :joy:


Is there a way to download roblox studio like this?

This is still occurring. Unable to install studio at all. Also unable to fully delete studio from computer

Trying to uninstall results in this, and it’s just stuck there

And the fact no devrel has responded to this in weeks is kinda concerning. Should chuck CRITICAL in title to get their attention. To me this is a serious issue, as people are unable to download Roblox whatsoever, both player and studio.

1 Like

possibly any updates? this is a veryy high priority issue, not being able to install the game or studio means you can’t play roblox at all or develop at all… how is this taking a month?

Happening to me today


2023-11-08T22:23:38.004Z,0.004779,2374,6,Info [FLog::DesktopInstaller] The installer reporter is initialized
2023-11-08T22:23:38.004Z,0.004814,2374,6,Info [FLog::DesktopInstaller] The command line: "C:\Users\Seafoam\Downloads\RobloxStudioInstaller(1).exe" 
2023-11-08T22:23:38.004Z,0.004856,2374,6 [FLog::Error] Failed to delete channel from 'SOFTWARE\ROBLOX Corporation\Environments\RobloxStudio\Channel' for baseUrl 'www.roblox.com'
2023-11-08T22:23:38.004Z,0.004870,2374,6,Info [FLog::DesktopInstaller] Reporting Installer Start
2023-11-08T22:23:39.155Z,1.155083,2374,6,Critical [FLog::DesktopInstaller] C:\buildAgent\work\ci_deploy_ninja_boot-x86_git\Client\Installer\Windows\src\Dialog.cpp(292)\RobloxStudioInstaller(1).exe!00198665: (caller: 00197DF1) FailFast(1) tid(2374) 8000FFFF Catastrophic failure


2023-11-08T22:23:41.003Z,0.003796,1ec8,6,Info [FLog::DesktopInstaller] The installer reporter is initialized
2023-11-08T22:23:41.003Z,0.003837,1ec8,6,Info [FLog::DesktopInstaller] The command line: "C:\Users\Seafoam\Downloads\RobloxPlayerInstaller(2).exe" 
2023-11-08T22:23:41.003Z,0.003875,1ec8,6 [FLog::Error] Failed to delete channel from 'SOFTWARE\ROBLOX Corporation\Environments\RobloxPlayer\Channel' for baseUrl 'www.roblox.com'
2023-11-08T22:23:41.003Z,0.003890,1ec8,6,Info [FLog::DesktopInstaller] Reporting Installer Start
2023-11-08T22:23:41.734Z,0.734116,1ec8,6,Critical [FLog::DesktopInstaller] C:\buildAgent\work\ci_deploy_ninja_boot-x86_git\Client\Installer\Windows\src\Dialog.cpp(292)\RobloxPlayerInstaller(2).exe!00A486AF: (caller: 00A47E41) FailFast(1) tid(1ec8) 8000FFFF Catastrophic failure

This has happened since my client closed with “Roblox needs to update we’re sorry” or something like that.

Both my client and studio are broken.

I have uninstalled the client, uninstalled the studio, fully removed all the folders in appdata, I have removed all registry entries related to Roblox and still it will not update nor install when running either of the two client or studio installers.

I can provide a DMP if needed.

It has stopped crashing as much, but its still horribly slow to download.
This is not because of my internet speed, I can download other apps relatively fast.
This just takes way more than it should.

This issue still persists. From today’s Roblox update it seems that even when force running both RobloxPlayerInstaller.exe and RobloxPlayerLauncher.exe in administrator mode, the installation still gets stuck and eventually crashes.

1 Like

My roblox studio crashed with reason “no verified patch could be loaded”, none of my work saved.

Stillll waiting. 2 months. I am just passing by.
I made a topic about this as well.

You can install Roblox Studio from one of the recent Temp Roblox folders. Not so sure about Roblox Player though, it freezes if you try and load in a roblox “experience” if you installed it from one of the Temp folders.

Mm, might as well play on my Honor x8 instead.

1 Like

i hade the same issue 2 days ago, and still i can’t fix it (i reported the issue using roblox support)

I used this method, it fixed the instal issue but when i join a game the roblox lancher crush after like 1min

I’ve also noticed that when you first launch an experience, that the Roblox loading screen does not move anymore and noticed it when this issue first popped up. Maybe that issue is related to this? Because it seems it’s a Roblox Launcher/Player issue.

I was about to make a separate bug report, but I came across this topic so I guess I’ll drop this here:

So, it goes like this:
And then just disappears.

This first occurred to me on 15th of November. I tried deleting all (I think?) Roblox files, all registry keys etc., to no avail. Surprisingly, taking my friend’s Roblox folder from AppData/Local and pasting it in there on my user account did the trick - it also started actually downloading things (previously the installer was going through suspiciously fast).

I was expecting it would be working properly from then on, but no. On 19th of November (today) I have the same issue again. Except the installer closes itself at a different progress percentage. Uninstalling Roblox properly (via the uninstaller) does nothing either. (Oh, by the way, it left half a gigabyte of garbage in the app data folder…)

I could live with this, but grabbing a copy of a Roblox install from a friend every update is just not feasible. And there seem to be other people facing the same issue too, although it’s quite rare.

This workaround has done the trick for me, thank you!!!

1 Like

I’ve been getting this same issue on many computers. But without having the launcher exe I cannot do the workaround.
On top of that it takes 20 minutes to even open roblox. I tried clearing literally everything from reg edit related to roblox and every file associated with it and it still won’t work.

1 Like

This is still happening with newer versions btw. Both for me and my sister, on the same network (4g mobile broadband)