I can't add "Shirt Templates" by scripts

I had never tried adding Shirt Templates to the “character” however the id will never load, I tested it with these 2 ids: 5520306054 (image)
4637611578 (ShirtId)

The script I made:

local test1 = {5520306054}
local Character = player.Character or player.CharacterAdded:wait()

Character:WaitForChild("Shirt").ShirtTemplate = "http://www.roblox.com/asset/?id="..test1[1]


In the output it will give this result:image

What am I doing wrong?

I think you need Character:WaitForChild(“Shirt”).ShirtTemplate = tostring(“http://www.roblox.com/asset/?id=”…test1[1])

1 Like

nothing happens now, no output error

Do I have to use a service like “httpservice” or “insert service” or “MarketplaceSerivce”, to get the id to work?

I think you need to insert the image of the template on the game explorer

I have NPC models that include clothes and work in the studio so that when I play, they disappear and there is a request failed error.


Where is that error coming from?

The error comes from the line “Character: WaitForChild (” Shirt “). ShirtTemplate =” http://www.roblox.com/asset/?id="…test1icando1] "and also from what I see now the textures that give error are located in a replicatedfirst gui

*Character.Shirt.ShirtTemplate = “http://www.roblox.com/asset/?id=”…v

Add a tostring in front of the shirt id

Character.Shirt.ShirtTemplate = tostring(“http://www.roblox.com/asset/?id=”…v)

1 Like

I had added it before but did nothing

I tried it in my own game. I used a decal I had and it worked.

1 Like

Maybe there is a problem with the image?

the problem is really my image, I tested it on another one and it worked.However, I didn’t understand why it doesn’t work with the one I put before

Ok so you found a solution to the issue?

1 Like

Unfortunately not in spite of working with other images, the one I want doesn’t work, I’ll research it better and thanks for the help

1 Like

I already found an alternative solution, thanks anyway