I can't animate skinned meshes?

I just want to animate a skinned mesh, but it wont let me click on the bones or attachments, which means I can’t animate my character that I made for a game that I’m making, which is supposed to be the avatar style for the game.

I tried doing it after clicking the plus button and adding all bones, but it still didn’t work… I have looked in a lot of places and have been unable to find any instances of other people having the same issue. I also don’t know how to animate on Blender, so that’s another issue.


In my opinion, it is easier to animate in blender (since you can select the bones by clicking on them, and you have the possibility to use inverse kinematics and other constraints), but to do it in studio, you have to do the following:

  1. Open the animation editor plugin and click on your character
  2. Add an animation track by clicking on the little + icon.
  3. I recommend clicking “add all”, but it depends on the number of bones you have. What it will do is activate keyframing in the selected bones.
  4. Now, normally, the bones should appear on the bottom left of the editor, and you should be able to select them from there and use the regular move, scale, and rotate tools. But i’ve had a case where i couldnt add any keyframes, so im working on it. Edit: it was broken because i added a part to my group, that wasn’t in the fbx file

I did add all, and I tried clicking on the bones in the animation editor window and it didn’t work either? Since I’m extremely inexperienced with Blender animation, it would be harder for me. I just recently started learning Blender, and I’ve only been learning modeling so far.

1 Like

did you select the rotation or move tool of Studio after clicking the bones in the window?

1 Like

Now it does, but rotating bones doesn’t affect the mesh. I tested in Blender using pose mode to see if it works there, and it does.

i meant in the animation editor window

Sorry about the confusion, I did it in the animation editor window and it let me activate the tools.

1 Like

Do you consider this topic solved then?

Kind of, but rotating or moving doesn’t affect the mesh at all, which is weird… I have tested using pose mode in blender, and it works in blender. Got any idea of what might be causing this?

It does that when you have tried moving the mesh outside of the animation editor (like just the mesh without the bones) i have no idea why

1 Like

It didn’t work in the editor either, that’s what confuses me…

Yoo did it just get super laggy in the edit mode? My studio updated and it is now 12 fps, and it was 60 before.