I just published an animation, but when I try to import it again it says it's not owned by me, when it is

1 Like

There was no category this fit under, sorry!


Try to search your animation on Web, go to its web page, copy the ID of the animation (for example, for a link “https://www.roblox.com/library/*id*/…”. Copy the ID after library)
Go to roblox studio, go to the import page and paste the ID in the box on the left of cancel button.

Try that


Nope, that didn’t work… I don’t know whats happening

1 Like

Are you selecting the same selection page? For example:

  • Is your game in a group page or your profile page?
  • After answering the first selection, tell me if the animation is published in your group page or profile page

Those can be the causes. Not be in the same development account link

1 Like

Answer the dots, please. It’s important so I can know and can help you

1 Like

It’s published to my account, yes, and same with the game.

1 Like

the animation is published in your account? what about the game?

1 Like

Also created under the same account…

1 Like

Try to publish again the animation (if you can)

And then try

But i have a question

Do any of the other published animations import to your game?

1 Like

Yup, all the other animations work except for the most recent 2… I even thought about downloading the model through the version history thing but it saves as an empty rblx place file

Maybe they got corrupted? I restarted my computer and they still didn’t import, but luckily they were the least complex ones I made today…

Actually, I tried downloading a working animation and it was also a blank game file, so I dont know…

1 Like

yes, luckily.

but is your problem solved? Did you try to do it again/publish it again

I overwrited the animation and it SEEMS to be working now, I’ll let you know if it breaks again

remind me please.


Seems to be working fine now, thanks for helping!

Nevermind, literally right after I responded it happened again… I have no idea why this is happening!


Turns out Roblox was kinda down, but it’s kinda working now!

edit: ITS HAPPENING AGAIN maybe i just need to give it time?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.