I need help fixing a shop GUI, might be a bug, might just be my code

Before you read this, please know that I am really new to coding, this is my first game, so I was basically smashing together tutorials and improvising. I am making this minigame type game and in the game you can compete to get points you can spend in the shop. Well, another way I am trying to add to get points is by buying them in the shop using devproducts and such. I managed to get one option to work (buying 100 points), so then I copied what I did to make the first option to make the second option (buying 500 points). The second option works, but the first one doesn’t anymore. I tried multiple fixes but none of them worked. Anyone got any idea on what is going wrong? here are some screenshots.


The script seems fine, but i can’t see the problem because you showed only 1 script. Anyway just make sure that each script of each button has its own dev product id and that each script gives right ammount of points for each dev product id.

I put both the local script and the devproduct handler in pictures. Do you think this could just be a bug in roblox sutdio?

you put a local script and a server script for a single button. And it should work fine. But i don’t see scripts of other button so i can’t say why it doesn’t work. Just make sure that local script and server script in 100 points button has same dev product id, and that local script and server script in 550 points button has same dev product id that is different from 100 points button

the scrips for the other buttons are almost the same, just different devproduct ids and point amounts. The only one working right now is the nuke button.

nuke? you said that 550 points button works right now

Well if it’s really as you said that only dev products ids are different than i can’t tell you what’s your problem since it should work if it is like you said. But i can tell you that it’s definitely not a studio bug and you should just check all ids again because i can suspect only that you typed something wrong

Ok, I am just confused because all of the buttons each worked at some point, just not when I added a new button. I have a hunch it has to do with the devproduct handler

I checked and found nothing wrong. It just wont work.

Yo, I managed to fix it all on my own. I just deleted all of my handlers and made a new one in server script service.

it works!!!