I need help hiding my secret area

I have a hidden area behind a No-Collide wall.

But as I move farther away, it becomes obvious there is something unusual happening there, and spoils the secret.

What is causing this issue? Is it my crappy laptop? Is it an issue with Studio? Lighting/Shadows?

Any recommendations for fixing it?


Did you place any lights there in any part cause if so it will maybe be the isue if not try to do you grafiqs up to the max and test it cause it’s possible that it happens cause your grafiqs are to low.

1 Like

There are no lights inside, but messing around with it, it would seem that the shadows from the adjacent cliffs do not render if I am too far away.

You are probably correct that it is due to my graphics settings being so low, but I wonder how I might combat this issue for players who are also using weaker machines to play on.

Could just put some trees there so that if their not close enough itll just look like trees glitching?

I think its probably going to be because of graphics quality. The higher your graphics quality is, the better the depth of view will be from a far distance.

I think you’re using a normal graphics quality in Studio, if look closely, it looks like its hidden, but from far, its kinda revealed.

Go to File > Studio Settings > Rendering >And set the Level01 to whatever the the “level” of it but higher than that, like Level 08.

Hope it helps!