I need help with a lag problem

ok soooo im making a game and each room kinda has a lot of meshes / parts but their all 3k parts or under yet for some reason even if i put every single map in server storage except for 1, when u play the game and ur inside the map the game lags a lot… I have been planning out this game for a long time and stuff but this could just ruin it all so like if somebody could help me figure it out or smthn i could even give edit access so u can see it for urself. srry for my bad grammar btw im just stressed out so i dont rlly wanna correct it all.

1 Like

Is this in studio or in game?
What is the RenderFidelity of the meshes (under properties)?

the meshes r at default and its laggy both in studio and in game

i can give access to a copy of it so u can like look at it or smthn

I don’t need access but please show screenshots of the meshes and how many there are.
Make sure RenderFidelity is Automatic and your studio graphics settings are low.

Its a mixture of both parts and meshes but this is smthn that is mainly meshes… and this room only has like 1/2 compared to the rest…

And yes the meshes r on automatic

Seems that it is definitely just too much meshes in one area. I can see you have almost 300 selected there. Try using more parts or some unions and a lot less meshes :+1:

1 Like

I tried that in a different room using more parts and unions but then the part count came to like 5,000 and it lagged becuz of that… This room i showed u isnt even finished after selecting everything with a finished room its over 700 selected. I guess I will just try to make simpler builds for an actual game or smthn idk.
heres a picture of a diff room btw


That’s really just client-side.

You can’t really do anything about that except to reduce the number of meshes.

You could also try adding a sort of “Anti-lag” option that makes all textures into plastic and makes the lighting technology into Compatability.