I Recalculated Normals, but It looks inverted on studio

Hello! I was making a glock model for my fps game.

I always recalculated the normals(Shift+N) before exporting the mesh to studio.

I turned on the Face Orientation and It says there are no flipped faces.
and This also shows that there are no flipped sides.

I also tried triangulating the mesh. but nothing has changed.

3
But this is what my mesh looks like on studio.
You can see parts inside the slide. because the slide rendered invert.

4.PNG
when I turn on DoubleSided, the slide rendering weird.(Light shading inverted?)

(maybe sorry for bad grammar, I’m not god at English)
I’ve been trying to solve this problem for hours. help!

1 Like

this just happened to me like 30 minutes ago! The only reason I can think of is that my scale for the model was negative in blender :man_shrugging:

1 Like

Hii babs im not active here, so sorry for the delay in responding.
To fix that, click on the down arrow, and then in ´´face orientation´´
All faces must be blue, if there is a red face it is inverted, just select it and press ´´ctrl n´´
Hope this helps!

2 Likes

Adding on to this you might also want to Ctrl-A > All Transforms (Might fix the shading issues)
Also when exporting FBX from Blender into Roblox set the scale to 0.01 while exporting

1 Like

If they haven’t set up their units/scaling yet, that’s a good idea. If their unit settings look like this, the FBX export scale can be left at 1, as the model was already at 0.01 scale in Blender.
My standard Blender unit settings: centimeters at 0.01 scale.

I don’t know why (I’m a beginner at Blender), but I did Ctrl-A > All Transforms and recalculated the normals, and it was fixed perfectly! You are my lifesaver! thank you!

Unrelated but what is that Blender theme :face_vomiting: