I tried reinstalling Roblox, and now I can't play

Once I reinstalled, it never opened the game. I’ve done this like 5 times. It always shows “Check Always open links for URL: Roblox Protocol and click Open URL: Roblox Protocol in the dialog box above to join games faster in the future!” at the bottom, but it never pops up with the box so I can check it. I’ve tried to mess around in some files on Google Chrome to try and make it come back, but nothing is working. Does anyone know a solution? Studio opens and works fine btw. I have also deleted my LocalAppData files for Roblox.

Edit: Tried it in Google Chrome & Microsoft Edge and it still doesn’t work.

Edit 2: I’m almost positive that it’s the External Protocol Handler, but I have no idea how to fix it.

24 Likes

If the external protocol handler isn’t working, a random google search gave me this fix: https://thetechjournal.com/how-to/tutorial-how-to-re-authorize-opening-of-external-applications-from-google-chrome.xhtml (Windows)

Does it work on Firefox? Whenever I’ve had an issue with Roblox that is based on a browser, Firefox has always seemed to work. Might be at least a temporary solution.

1 Like

I saw that tutorial. It didn’t work. I’ll download Firefox right now.

Edit: Firefox somewhat works… when it asked me what to do with the External Protocol, I chose the RobloxPlayerBeta application, but now it says this in-game.

At least we 100% know that the protocol is the error.

3 Likes

Try checking the console in all of the browsers you use to test with when you try to launch Roblox.

When I was having issues with launching Roblox from my browser, the console had a warning message that diagnosed the problem for me.

Found the error. Roblox is trying to use http, but it is hungry for https?

1 Like

Yep, that’s it.

That was the issue for me, too. Seems it applies to all Chrome browsers (I was having the issue with Vivaldi).

The issue was solved for me after a Vivaldi update, though… you may need to wait for the next Chrome update that solves the issue.

Until then, if you want to play games/open studio from your browser (the latter wasn’t working for me, either, although you might be lucky) you’ll need to use another one (like Firefox, but it seems that doesn’t work for you either).

Maybe a solution could be to re-install Chrome?

Reinstalling did nothing but reset all of my settings for every extension I had. RIP me. This is making me mad.

3 Likes

Yeah, I guess you’ll have to play the waiting game

Try DMing @LordRugdumph
He was the one who contacted me about the issue I was having, and this is essentially the same problem

1 Like

Yes

Didn’t work

3 Likes

The exact same thing happens to me now. I also get “Check Always open links for URL: Roblox Protocol and click Open URL: Roblox Protocol in the dialog box above to join games faster in the future!”, but there’s no a checkbox like that in the dialog box. Only “Open Roblox” and “Cancel”.

I have to manually allow Roblox to open every time I hit Play :confused:

Any news on this?

I had to factory reset my PC… very unfortunate that I never found any other solution. Good luck

Funny thing is…
Everything was working before. I did a factory reset 2 days ago, and now it’s not working lol
Thanks though