Icon won't load

  1. What do you want to achieve? Keep it simple and clear!
    I am trying to upload a developer product icon, except for some reason it won’t let me upload it.

  2. What is the issue? Include screenshots / videos if possible!

It never stops loading.
3. What solutions have you tried so far? Did you look for solutions on the Developer Hub?
I tried using .png and .jpg file types but neither worked. Does anyone know what’s going wrong?


Has this happened to you before?

It hasn’t this is the first time.

Are you able to upload icons or is it just me?

I think it’s just you, did if pass moderation?

That’s a good guess but it wouldn’t make sense because I have tried uploading like 5 different icons.

How is image.png inappropriate text?!

This has been happening to me as well for multiple weeks, no idea why it’s been happening. The only way I can upload or edit developer products is inside of the game settings under monetization, and I cannot upload an image. Wish that Roblox would fix this, lol.

1 Like

I think this is why

Yeah, I mean this sort of that is so important, that if it doesn’t work correctly you have to delay the release of a game.

Hmmm, that’s a good point. I’ll see if the problem consists in the weeks to come because this is something that has to be fixed.

this is currently an Website bug I will link the Bug report so you can look at it yourself and if you should look at it yourself you can Activate the Watching option to get a notefication if something should happend in the post

i hope i could help you!

1 Like

The error msg is inaccurate, it could be the actual title of the dev product, or the file name. Make sure to check both.

1 Like

Thanks for letting me know. All there is to do now I guess is to hope it’s quickly fixed. :man_shrugging:

Yeah that’s the only solution at the time if you want you can mark my reply as a solution and i will update you if i can provide you with an update.

Alright, I marked it as a solution.

what about mine lol it’s the same thing

No it’s not your issue did only effect the Marketplace/library so this has nothing to do with Developer Products.