IconImageAssetId returning as 0

So, in MarketplaceService:GetProudctInfo() the IconImageAssetId, keeps returning as 0, i know that because when i go to the ImageLabel in my Template, it says rbxassetid://0 and i tried everything even specifying the AssetType in the parameters, but its still not working

for s, item in pairs(assets) do
		local info = mps:GetProductInfo(item["id"], Enum.InfoType.Asset)
		local template = script.Template:Clone()
		template.ProductImage.Image = "rbxassetid://"..info.IconImageAssetId
		template.Parent = frame
		template.ItemID.Value = info.AssetId
		table.insert(_G.buyButtons, template.Buy)
		frame.CanvasSize = UDim2.new(0, 0, s/10, 0)

Did you fine a solution? I am also trying to figure this out.


for s, item in pairs(assetsInInfo) do
		local template = script.Template:Clone()
		template.ItemID.Value = item.AssetId
		template.ProductType.Value = "Asset"
		template.ProductImage.Image = "rbxthumb://type=Asset&id="..item.AssetId.."&w=420&h=420"
		template.Parent = frame