Idle animation is acting up

  1. What do you want to achieve?
    I want to have the correct idle animation (one that I made on animation editor) play in the game.

  2. What is the issue?
    Well for some reason, the characters idle breaks completely, and that breaks the walk completely, and the character sinks into the ground?? Another issue which is so odd to me is that the arms of the character start to follow the mouse? The whole animation is completely broken, but will work perfectly fine on any animation editor. Refer to videos below on what the issue looks like.

  3. What solutions have you tried so far?
    I’ve tried searching devforum, but can’t find anything as extreme as this scenario.

I made sure to have the animation priority set to idle, and I also made sure to correctly set the players idle using a script in ServerScriptService. I don’t think this is a script issue, it must be some kind of bug or something that I have to disable. Please do help, as I am so confused.

How the animation looks in any animation editor:

How the animation looks like in game:

change the priority to movement instead of idle
also why are you even sinking

I have no idea, I have like no scripts in the game besides the one that sets that animation to the idle, so it shouldn’t be any kind of script issue. I think it has something to do with the animation but I have no idea.

Also, setting it to movement didn’t change anything, so I am not sure what the issue is.

I figured it out. Nothing was wrong with the animation or script. Something was bugging in my game, and that was happening even when I deleted all the scripts and everything from my game, so it was something game side. I copied the important stuff from that game over to a blank new game, and everything worked fine. Hope this helps if anyone has the same issue.

EDIT: I figured out that it had to do with setting the games characters in gamesettings to force r6, for some reason it bugs out completely.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.