Idle Animation2 Not Functioning Properly

While working on custom R6 animations for a game I dev on, I decided to add some spice to the animations. Usually, I’d delete the second animation instance, and the idle animation would work just fine. However, when I tried to put in my animation (rather than the standard, boring roblox one…) it decided to just… semi-work? The animation will occasionally play, yes, however it seems as if once the animation stops, the underlying idle animation does not continue. Image below is what occurs upon ending the animation.
image

2 Likes

is your Idle Animation1 the same as your Idle Animation2?

No, Animation1 is different from 2. It might be the fact that Animation2 is unlooped? I thought the foot sway was an action, not an entirely different idle animation.

Can I see your script? letter letter

It’s just the default roblox animate script that is automatically put into your char once you load in, animation1 is a looped animation, animation2 is not. Nothing else is changed.

i understand that this is still an old thread, but most likely that since it is an action it ovverides the movement, making it stop playing

I solved this a while back, my mistake for not emphasizing; i thought that the idle2 animation slot would simply be an action-level priority animation that would play alongside the idle1, however, idle2 is simply just another idle animation. You are required to have it loop if you want it to work correctly.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.