IgnoreGUIInset Disabled Automatically on Previously Enabled ScreenGUIs

Reproduction Steps

Open a place that previously had IgnoreGUIInset enabled (before today). You’ll notice that the property is now disabled. Seemingly all UIs that had the property enabled now have it disabled, confirmed by other developers as well. This did not publish the place live, but when you open studio it is there.

Expected Behavior

The property to maintain its defined state before today.

Actual Behavior

The property was automatically disabled.


Go to each ScreenGUI you know had the property enabled and enable it manually. Just a nuisance to correct automatically set behavior, especially if you didn’t notice it before publishing your experience live.

Issue Area: Studio
Issue Type: Other
Impact: Moderate
Frequency: Very Rarely
Date First Experienced: 2022-12-09 00:12:00 (-05:00)


Hi @Shawnyg - thank you for the report! Did you opt into the notch studio beta? Does the issue still occur if you opt out of the beta?


Hey @DrRanchDressing ! Thanks for the swift solution. I forgot I had “Enroll in Beta Channel” enabled, which auto opted me into the beta. Disabling the beta feature reversed the effects. Didn’t notice that important issue on the devforum post before.


Is this a bug or is it a feature of the beta program?

1 Like

Hi @Shawnyg - glad to hear that solved the issue for you! We’re hoping to get this bug resolved soon. Thanks for the report!

1 Like

Hi @madepossibleby - this is a bug that was introduced with the launch of the Notch Screen Support beta:

To resolve this issue, please turn off the Notch Screen Support beta in Studio’s Beta Features dialog (accessible via the File menu).

We’re hoping to resolve this issue soon!


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.