I'm getting the "Cannot load published place" error

I apologize for my wrong use of categories but I do not have access to studio bugs category.

I’m trying to load into my place recently to continue create assets.

I’ve been getting errors that wouldn’t let me enter my place. My place is published and
I’ve cleared any scripts existed in that place to ensure there’s no backdoors. I don’t know
if this is a loading corruption or any sort of corruption (if it is please let me know thank you).

I tried restarting studio several times, restarting my pc, update my graphics drivers, revert it
to previous version. After all of those attempts, nothing worked. I don’t want to loose my days
of work.

https://i.gyazo.com/8b69f0c388abbdd21a3de69dfb23ea59.png – The Error I’m Getting.

If there’s any info regarding this issue please let me know thank you very much.

1 Like

I’ve also faced such a problem some time ago.
Have you tried reinstalling Roblox Studio? I’ve did that and that helped me, however I’m not sure if it would work for you. Just if you don’t know, after reinstalling Studio everything is as it was be earlier.

This should help.

1 Like

I’ve tried doing so a few hours ago and yet nothing changed. Thanks for the suggestion though!

Well, if that didn’t work there is a few other solutions that could possibly work:

  • Go to …\Documents\ROBLOX\AutoSaves and try to find some AutoSaves for your place, and try to open it,
  • This one may be alittle bit harder:
    Download the BTR (Better Roblox) Plugin for your Browser, Go to your place Roblox Page, click the 3 dots and press Download. After it finished downloading your place, you should be able to open your place without any difficulties.
  • Contact Roblox Support,
  • I may probably think of some more solutions in a while, but as of now these are the solutions that may work.
1 Like

Oh, and just so you know - upgrading your graphics driver and similar to this has nothing to do with a place timeout error, it’s most likely because of file errors while trying to launch the place.

The BTR plugin will do as a solution for now. I will try to open studio from a different device to see if I could access my place from there and if I could that means the studio on my pc have an issue.

Thank you for listing the possible solutions!

Turns out I can open the place from another device so that means the issue lies within Roblox Studio itself.

What I did was go to AppData > Local and cut the Roblox file and store it somewhere else as backup if anything wrong happens. Then I downloaded Roblox Studio’s setup and reinstall Roblox. After that, I boot up my place and it works!

The BTR plugin without a doubt still useful.