I'm not sure how to stop light from coming through walls

I want to make it so light only comes in through the glass spots on the window I made.
The issue is that when I tried doing this the light went through the walls entirely. I tried point lights and spot lights but it didn’t work. This is what is looks like:


But I want it to look a bit like this but also split into 4 parts (made using a part):

I looked on the Roblox Wiki but I have no idea how to find stuff on there. I tried different lighting and I have the parts can collide turned on. The walls are 1 stud thick and the transparency is set to 0. I saw other projects and it looks like lighting doesn’t go through the walls for them so I don’t know what’s happening here to cause this.
This is what I have set for lighting:


I don’t even know if this effect is possible. I got rid of the parent part of the image bc I want at least some aspects of my project to be a secret until release of the game so I removed that so the name of the game isn’t known.

3 Likes

Try making the walls thicker (like 4-5 studs).

There is a slight problem with that though, the window shows the outside of the room, which will also show how thick the walls are. (The window goes in the middle of the wall’s thickness)

I ended up using parts to create the effect I was looking for.


Now I just plan to add a dust effect (not sure how to do so yet). I might try to do it by using a particle emitter, setting the speed to a slower value, and other stuff.

To prevent this, set EnvironmentDiffuseScale and EnvironmentSpecularScale both to 0, or change to a dark sky.

3 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.