ImageColor3 on GUIs (Screen & Surface) causing images not to render at all on (my) Android Tablets

I am having a problem, where ImageLables do not show at all on some Android tablets when using ImageColor3 is used modify the colour of the image.

I am experiencing this problem on both SurfaceGUIs and ScreenGUIs. The issue persists with using ImageButtons instead of ImageLables.

I am unaware of when this bug started, I’m just working on a game and tablet functionality is important to me. It worked fine on android phones I’ve tried, so I didn’t think tablets would be a problem, but I found wrongly when I tried today.

Here is a repro:
Repro.rbxl (19.8 KB)
Intended appearance (on PC)

The image to the left on a 7 is a white image, using ImageColor3 to be made red, the other is a non-formatted ImageLabel

Devices Tested:

It works fine on my mobile phone

(Also works on my mothers ZTE Blade V7 Lite which I believe is Android 6.0, but no screenshot of that)

(There is another bug with Android rendering, when using the slice features of images, that the slice proportions seem wrong and you get weird stretching artefacts on the image, noted slightly on the blue square on mobile, though is a poor example. I am guessing android rendering is different to PC for performance, at which that seems an acceptable trade-off, but the image colour resulting in no rendering is quite extreme.)

I have asked friends - but all have had too old devices to run Roblox to test. I will add updates with more devices if I find out more.

Unknown Hawaii on Android 8.0: Works


I’m pretty sure it works fine on my Android 9 phone (OnePlus 5T) as I use ImageColor3 for a lot of things.

It would be interesting to see if it’s a version thing, but I don’t have a tablet. See if you can get hold of an Android tablet on versions 8, 9 or 10 to see if it’s just the version.

Out of curiosity I took a look at the market share as of April 2020, there are still nearly 28% of users on Android versions below version 8, so if that’s the cause that could easily be a huge chunk of players.

1 Like

Am trying to, just don’t want to shell out £150 or so and have it not work. If anyone else has any recommendations please let me know!

I don’t see any issue with my Android 10 (OnePlus 7T) and my old phone which is Android 8.

Psss, have you tried emulating Android? You should try emulating Android 7, 8, 9 in your PC.

However, from the pictures you sent above. It seems like mobile devices with larger DPI will have a higher chance of not being able to see the 7 image. You may want to try setting your tablet to a lower DPI in developers option.

Don’t really want to emulate Android, giving me nightmares of a previous education coursework project :scream:

Took me awhile to find, “Minimum Width” was what seemed to be that setting on my device. Didn’t make a difference.

It works fine on mine & my mothers phones which are Android 6 & 7, so I’m not really too sure what the exact issue is. I thought it was just a niche problem with my Asus tables, but given it also doesn’t work on a rather mainstream cheap kindle, I thought it was probably worth a bug report.

1 Like

Thanks for reporting this and for providing a place that reproduces the issue! I created a bug to investigate this.


Hi @centraltrains, thanks for the simple test case. It looks like our old texture compressor wasn’t generating a complete mipmap chain (bug), and certain older gles 2 devices like the Kindle Fire 7 would fail to load the texture since they require all the mips.

We’ll put in a fix sometime within the next few weeks. You can also try re-uploading the texture to see if that fixes this particular case. (I’m not sure if you need to change the image slightly to re-trigger the compression.)


I’m having the problem with all 13 textures I’m using in this way, so I’m not sure that re-uploading would work.

Thank you for looking into this! :smile:

We’ve put in a fix, but it will take a few weeks before it’s live. Another thing which might work is to use square textures. But this should be fixed without workarounds once the fix is live.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.