Immersive ads appear to cause error 277, kicking out all players if ads are present

Experience which I haven’t updated in months suddenly started kicking out players a few hours ago:

When you join the game, after about a minute you see this, and players are reporting seeing the same:

Screenshot 2023-08-29 at 19.28.02

I don’t think it’s about memory use (server avg 2.3GB, client avg 1.5GB), because the game has not changed at all in months and this suddenly started. This also started happening at the same time to another game I have, which would also point to some issue on Roblox side and not an issue with this particular game.

Oddly enough not all of my games were affected, only Cat Trip and Bad Cat. The only thing I can think of that is different between these two games and my unaffected games is that they have immersive ad units.

When I got kicked out there were no unusual messages in server or client logs.

As you can see it affects all platforms.

I tried republishing the game and shutting down all servers, but it did not help.

Update: the problem seems to disappear if I remove all immersive ad units.

My use of ads may differ from most experiences, in that I replicate levels and the ads in them only to players who are currently in those levels. Possibly ads no longer behave well when sent over like this (replicated by putting the ads and the level under playergui and then copied to workspace via localscript).

Update 2: instead of removing all ads, it also worked to keep the ads always loaded under workspace instead of replicating them dynamically


Thanks for the report. We’ll follow up when we have an update for you.

This should be fixed by now. Closing this issue.