Importing Models from Blender

Hello Developers

So a couple of days ago I was trying to export some simple models from blender to roblox studio. It was a simple diamond mesh and this pops up:

I was asking people in the Hidden Developers discord server and the best answer I got from them was, “Roblox might think the model inappropriate.” It’s literally a diamond lol. I’m not that desperate for this as the dev that I was supposed to work with is on a burnout but yeah.

Any solutions?


When importing a Blender Model into Roblox I believe there’s a limit of 10,000 triangles. Have you checked how many triangles your model has ?

1 Like

What are you asking? I am guessing you are getting a error when you try to upload it but you have not really put anything explaining the problem in. Try what @MosesTheRedSea put as there is a limit and make sure you have the right file because often people do not get the right file uploaded.

1 Like

Roblox only accepts .obj and .fbx files.

They also have a limit to how big the mesh can be.


Try to export files by using obj, or fbx files. I doubt there is any limits. Since blender models are not even laggy.

Yes it is under 10,000 tris in fact its under 1000. I also exported via obj.

I’m asking why it’s not letting me import it. Yes it is as obj and yes it is under 10,000 tris.

If the amount of triangles is not the problem have you thought of making selections and exporting individual parts of the whole model. And then once your in studio you could reassemble them.

Try FBX and use a Mesh part Maybe.

Roblox does this a lot to me, doesn’t let me import a mesh because it was inappropriate, but usually if that was the reason you will get a warning next time your on Roblox.

Have you tried Re Exporting it from Blender as a new file? sometimes that works, also how are you Importing them into studio, Try using a mesh part, then from the mesh part insert the file.
Otherwise going back and Re creating/Editing the model (Using Modifiers) can usually help if it was classed as ‘inappropriate’ Not sure if this will help :slight_smile: but good luck, I hope you find a fix

1 Like

I’ll try that maybe it’ll work. It could also be the name. The name is “diamond” but ye lol. Thanks so much.

Yes its a mesh part btw.


I could try that, but like I just wanna know why it’s not letting me import it. Thanks for the help, if no better answers come up, I’ll put this as the solution.

1 Like

I’ve imported a few meshes and never got any error message that looks like that.
Are you putting a MeshPart into the workspace, selecting the MeshPart, then clicking on the file folder icon to upload your Blender .obj file?

Roblox has a triangle limit, of 30,000. You can either export as a OBJ. or FBX. What blender updated version are you using? 2.8, 2.81, 2.82, 2.83?

Yup 2.83. Yup its under 1k tris too. I used obj.

Could I see the error your getting?

Yup I am exporting via obj and it’s not working. It’s an issue with roblox thinking something strange about my model I think.

Interesting, I had the same error. It should fix over time.
Try a different mesh.