In Test Mode, Start with Future Lighting = ON

I have a 3090 RTX and every time I enter test mode in Studio, it takes 45 seconds for Future Lighting to turn on and for my shadow casters to start working.

If you’re tweaking lights, it’s not great.

Can it just remember and use the setting from the last time it ran?

Can I force it to just always be on?

22 Likes

This morning I was trying to debug some code that makes Water transparent if the camera is not in it and opaque if the camera is in it.

I wasted 30 minutes figuring out why it wasn’t working and then I found out it’s because Roblox starts on some low graphics level where water is always opaque.

ARRRRRRRRRRRRRRRRRRRRRRRGHH

It’s frustrating when you can’t trust your tools. Please send help.

3 Likes

Maybe check the quality levels set in Studio Settings under the Graphics category?

4 Likes

I found those eventually.

I think the default needs to be better still.

1 Like