Incorrect pivot or something idk

I was animating an idle animation and suddenly this happened

As you can see, the rotation thing is not centered and instead is set to the right.
I guess this is a pivot issue of some sort but I don’t know how to revert it.
(btw pivots on the character are correct when not in animator)

1 Like

The ‘L’ indicates it is in localspace, that is to say the pivot is oriented to the part instead of the world.
If you right click the part you should get an option to ‘use world space’.
I think there is a button on the model tab which also does this (I don’t have studio open, and my memory is rubbish for details like this!)

Also just thought, the animator editor might move the pivot to the joint attachment, but I’m not too familiar with it.

i gotta go but i did some testing and uh yeah
there was no use world space option upon right clicking (out of the animator)
as for the button on the model tab, I think you mean the Reset pivot tool or the Align tool.

the edit: i’ll try tommorow to mess with the joints, thanks for mentioning!

I’ll try what you said tommorow, thanks for helping!

CTRL + L Should fix it back to World.

1 Like

it pretty much just changed from local moving to global moving
(btw this happens both in roblox’s built-in animator and moon animator)

I installed RigEdit Lite and reset the joints (they were at the top corner)
And it worked! The joints are back to normal.
Thank you for helping!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.