Installer crashes immediately

Relevant System Information:

  • CPU: 11th Gen Intel i7
  • OS: Windows 11

Repro steps:

Expected behavior:
The installation succeeds without issues.

Actual behavior:

The installer crashes. This also triggers ProcDump (dump files and log files attached privately).

It appears that the installer runs twice, for some reason? Maybe a failsafe to see if it works the second time.

WORKAROUND:
Using Bloxstrap appears to bypass the broken installer.

A private message is associated with this bug report

IMPORTANT NOTE: This also causes an issue with pre-existing installations, where opening the app normally is impossible as the bootstrap process fails due to the installer crashing.

However, using a custom bootstrapper (Bloxstrap), allows me to open the app normally, while still being on the latest version 618.

Deployment information:

I’ve had a similar problem whereby the game and studio kept constantly reinstalling and never opening properly - at times also just displaying this behaviour of being disinterested in doing anything. I have found that by uninstalling both studio and Roblox entirely and then installing them with administrator privileges rectified some of these issues that have occurred - although this may be a mere coincidence.

1 Like

Thanks for the report! We’ll investigate and follow up with updates.

1 Like

Hi @Judgy_Oreo, thank you for the report.
The error message looks to me like there was an instance of Roblox already running, and the Installer could not close it due to permission issues. Do you mind trying the following?

  • Remove the Bloxstrap installation at C:\Users\phoen\AppData\Local\Bloxstrap
  • Uninstall all Roblox installations, including any administrator installation
  • Open Task Manager and make sure no background tasks are running related to Roblox

Thank you!

1 Like

Deleting everything I could and re-running the installer I downloaded fixed the issue, but there was this weird thing I encountered before that where I could not delete the installer file in the version-bca459bcd1854ce4 folder, as it was “in use” by itself, despite Task Manager telling me there wasn’t a Roblox process running anywhere? This also resolved itself either when everything else was deleted, or I re-ran the normal installer. Very odd.

Bloxstrap also prompted me to close any running Roblox processes prior to me uninstalling Roblox itself, but trying to close it through the prompt seemed to have just silently failed because Explorer, as mentioned above, seemed to think Roblox was still running.

bloxstrap-weird-1

I’m not sure what to make of this. But, I think it was a Windows bug, maybe from me putting my PC into Hibernation instead of shutting it down, so not a fault of Roblox. Thanks for your help!

Awesome! I’m glad that helped. This is a weird issue… Is it possible that you were signed in as another Windows user that might’ve been using the same Roblox installation?