Insufficient Memory Message Upon Unioning A Complex Model

So lately I’ve been running into an issue, one which I suspect is a CSG error. Basically, when I try to union object with quite a few parts, ex. a sofa with beveled cushions, I consistently get this error:


I’ve tried testing to see if it’s a face limit error, but it doesn’t appear to be one. I’ve unioned more complex items without error (plus the error message isn’t the usual “Triangle Limit Exceeded: Limit abc, Needed xyz”)

The only reason I’m not starting in the bug category is I want to make sure that this is a studio issue and not me doing something wrong. Thanks for your time!


Make sure you have enough CPU memory left. Try opening the Task Manager of your computer and see if you have enough memory left.

Attempted the union while watching my Task Manager. During the operation, my CPU usage and CPU memory each peaked at 58% and 61% respectively (which was surprisingly high to me). However, there was still a whole 39% that studio could utilize for the operation, so I don’t think it’s a CPU issue. I’m currently running a i5-8250U 8 Core setup, which for all intensive purposes usually does just fine under pressure (my GPU is a bit lacking however. I can do 7 on Roblox at 60 fps, but I run GS:GO at 20 on low. Don’t think GPU is relevant to calculating the operation, but included it just in case).

Some questions:

  • How many parts were you trying to union together?
  • Were you trying to union any parts that were already unioned?
  • Were you trying to union any negative parts?
  • Were all the parts in the same parent?

Guessing by that screenshot’s background, not “quite a few”, but many more than that :face_with_raised_eyebrow:

  1. After using a part count plugin, the tally is 299, with 2 unique meshes.
  2. Nope.
  3. Nope.
  4. Yep, all in a generic model parent.

Some items have overlapping selection markers, making it seem like more. It’s still a lot however. There’s 12 cushions, one set for each seat (back and below), and all are beveled.

I’m going to assume this is just an error caused by studio’s CSG algorithm being stressed by the amount of parts being union. In the end, I ended up not unioning anything, since there was no part clipping, so all is well that ends well. If someone cups up with a more conclusive answer not based off of an assumption, make sure to post it so I can change the answer.

Hi, I was able to fix this issue, however the solution is a bit tricky and possibly tedious. It seems like this occurs only on models with lots of parts.

The first thing I did was looking for micro spaces in my model between multiple parts and drag them and place them onto another piece, so basically connecting them. They look like this.

The line is pretty hard to see but its there.

This is my model example from a mech.

Once I connected most or all of those in my model I took the model and put it into two unions. Because unioning gets rid of many faces on the inside of filled spaces, I made my armour larger on the inside so it would be inside the white piece on the bottom.

I then merged it into a single union which I was unable to do before.


TL;DR Look for those little micro spaces in your model so there are not any extra faces to union in the model. Less faces = less stress = maybe not “insufficient memory” message.