Intellisense isn't toggable anymore, and it's causing lag when scripting

With the last studio update, intellisense(I believe its what its called) has been turned on and I can’t find where to disable it(please correct me if I’m wrong). With that comes lag when I’m editing large scripts. For example:


This was with an empty place with one 10k long script, and it still lagged:



I take it this is win7? Monitor studio memory usage (Ctrl shift esc) in task manager and see if there’s a leak.

Yes it is.

Looks like now’s as good a time as ever to clean up those > 10k line scripts.

I know where everything is and I don’t need to modify most of that code again. Why dice it up when it might be best to leave it alone(if it aint broke, dont fix it) to avoid lag when roblox just created the lag with the update? Shouldn’t have to jump through hoops, the problem is not the line count.

edit: I do recognize how 10k lines looks bad, trust me I wish I had started the project in 2015 differently, but hindsight is 20/20 and what I have to lose by dicing up those 10k lines(new bugs, time spent, potentially making it more complicated than it needs to be) does not outweigh the gains(less lines and a few people who wont see my code being more pleased). Not to mention lots of games nowadays have thousands of lines just in data. All the data just for my skins is 4k lines, and it lags if I try editing it at times. Nothing I can do about that one, this is a roblox issue.


The comment was mostly in jest. I agree that this should be fixed.

1 Like

Having the same exact issue in my 16k line script, running Windows 10


Rip. Yeah, be making sure you are saving just incase lol.

Can we get a staff member here to tell us whats up? I didn’t really have to script when I made this post, but I do now, and it’s actually impossible to script. I’m getting like a frame a second or every several seconds.

Can confirm I’m having issues - modifying a script with ~ 2.7k lines of code and it’s lagging like crazy.

We turned off the update which caused this bug, which should resolve your problems.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.