Interaction with Script Editor really laggy on Windows

Whenever I open a script in studio I experience lag when moving my mouse or typing, but it only occurs in the script editor. I normally experience no lag when using studio’s script editor, but now it is occurring every time. It makes it extremely difficult to write code to the point where I’m just pasting the code from another text editor.

Steps to reproduce:

  1. Open any game in Studio (Could even be an empty baseplate)
  2. Create a Script object in any Explorer section i.e. Workspace, ServerScriptService, etc
  3. Double click to open the script
  4. Attempt to move the mouse or type while the script’s tab is open

Video showing issue: https://www.youtube.com/watch?v=o2gx_ncob8A&feature=youtu.be

I’m using a PC running Windows 10 (Not the Mac issues that had previously occurred) and I’ve tried reinstalling several times.

System specs:
CPU: i7-8700K @ 3.7 GHz
GPU: Nvidia 1080-Ti
RAM: 16GB
OS: Windows 10 Pro

I uninstalled ROBLOX Studio last week and just reinstalled it yesterday and this issue started happening.

3 Likes

This topic was automatically closed after 1 minute. New replies are no longer allowed.

1 Like
  • Does this happen with all plugins uninstalled?
  • Does this happen with autocomplete disabled?
1 Like

Yes, it occurs in both cases.

Can you attach microprofiler info / task manager screenshots? Instructions:

Sure, here’s the CPU graph
And here’s the microprofiler info:
microprofile-20190205-123328.html (842.0 KB)

These were taken in a ROBLOX game while also having studio open

I’m having the same problem. Is any solution available? It makes developing impossible.

CPU: i7-7820X
GPU: Nvidia 1080-Ti
RAM: 32GB
OS: Windows 10 Pro

A workaround is to unparent the script tab from the main studio window.

Having the same issue as well on both my systems… On system 2 however this goes as far as causing studio to lock up fully forcing me to do a hard reset…

System 1 (Dell Precision T7500 - No longer affected by issue):
2x Xeon X5690
64GB of RAM
nVidia GTX 980Ti

System 2 (MSI GS70 2PC STEALTH):
i5-4200H
GTX 860M
10Gb of ram

Both run Windows 10

If you disable the “Enable Autocomplete” setting, does this stop?

2 Likes

Having the same issue, except GPU is exceeding 78%+ during the lag, but I can’t screenshot since the lag freezes my whole PC

Windows 10
AMD Ryzen 5 2600x
AMD Radeon RX580
16gb of ram @3000mhz

EDIT: I disabled “Enable Autocomplete” in the settings (suggested by @Subcritical_alt) and it was successful in fixing my issue

We’re unable to reproduce at the office, so it’d help to have some more information in order to track this down. Can someone:

  • Make sure all instances of Studio are closed
  • Win+R, regedit
  • Go to Computer\HKEY_CURRENT_USER\Software\Roblox\RobloxStudio
  • Right click “RobloxStudio” in the left pane and select “Export” (remember where you export it)
  • Once exported, Right click “RobloxStudio” in the left pane and select “Delete”
  • Open Studio. If Autocomplete is disabled, re-enable it and restart Studio
  • See if you can reproduce the issue
  • Once done, close Studio and double click the exported registry backup to restore your old data

Does this also stop the issue? If yes, can you zip up the reg file and PM it to me?

1 Like

Seems to be a lil’ bit better on system 1 it no longer lag (the issue vanished as if nothing happened) but on system 2 (see my previous post here if you don’t know what I am referring to) I have not yet tried disabling autocomplete.

Anyways I’ll try getting a .reg dump from System 2 (as the issue is no longer occurring on system 1)

Edit: PM Sent.

EDIT: I found a temporary workaround. Moving the script editor tab to its own window allows me to edit the script without lag. If the tab is in the same window as the workspace editor, the lag resumes.

The problem…
When I edit any script in any place I experience massive lag which makes editing scripts impossible. I have no plugins installed, and no other apps open. It happens even if auto-complete is turned off. It happens even on a blank baseplate.

My CPU performance under the Resource Monitor claims to average just 4% while editing.
Despite this, my monitor flickers slightly, my cursor lags, and text input is delayed by more than a second.

This doesn’t happen in any other application or text editor. Just Roblox Studio 64 bit.

Here is my microprofiler dump. The Perform and Present spike incredibly hard when I open the script editor, but when I’m just viewing the workspace, the readout is typical.


microprofile-20190324-152340.html (1.2 MB)

Here are some specs
image
Graphics card: Nvidia GTX 1080-Ti

Let me know soon what I can do to get this working again. Currently at a standstill. :slight_smile:

1 Like

Hey Nvidia card guys @devTools @TheAddictPlayer @Destrings
For anyone still experiencing this issue, I found that disabling Nvidia’s Gsync circumvents it, might work for you too.

1 Like

GSync was already disabled on both my systems… The first system has a CRT (old but still going like a champ) monitor attached and with GSync enabled I would get not only lag in Studio but in Windows as well.

But yeah still going to note this as well.

Gsync did the trick! Hope they fix issue soon, it sucks to have an expensive feature disabled due to Roblox incompatibility.

Turning off G-Sync worked for me as well just now, still kinda surprised this hasn’t been fixed yet as G-Sync is a very nice feature I use on all of my Steam games.

Aaaand it’s back again, and to make the matters worse it slows down up until it stops responding (and gsync is disabled on both systems, it only crashes on my Dell T7500)

edit: Nevermind, I just re-enabled GSync and the issue vanished, after I updated my drivers to the version 430.39, probably a long shot but at least for me it worked on the T7500, on the MSI however it doesn’t do anything (possibly owing to the fact that it has Intel HD Graphics as the ‘main’ GPU…? it seems to happen when I run studio on the GTX 860M…)

I was told by EchoReaper that you can toggle Gsync per-program, might be worth investigating.
I turned it on for Fullscreen applications only, which is pretty much every video game I play.