Interesting shadows glitch in Future technology?

Is there a work around this peculiar shadow inconsistency that future shadows offer? I’ve been messing around with the materials service, but this is an actual in-engine bug, where at certain angles, the shadow that is originally there simply disappears! Are Roblox staff aware of this, and why it is happening?

For the record: I am using level 21 rendering, my lighting is future, and I’m using Surfacelights. I’ve also tried this with Spotlights/Pointlights and get the same effect.

Could it be due to the shadows being rendered in screen-space or something like that?

The textures also have a similar issue where you can only see the speculars when you’re facing towards a light source, but once faced away from it the speculars also disappear.

Note that I also found out that your characters shadows don’t render when in first person too…

1 Like

Are you trying to get shadows on all sides or no shadows at all?

Are you sure you have Shadows enabled on each one of the SurfaceLights?

Does this happen in-game as well, or just in Studio?
Is this a simple place with no lag or part of a large game that might have some lag issues?

It might just be.

There are no shadows because your character is invisible on default in first person. : P

Since the lighting comes from both sides two shadows should be present, the two shadows that you see should stay there in place, but with the weird way the light highlights the ground, the shadows disappear at certain angles.

Shadows are indeed enabled on each one of them. I’ve tested this by also publishing and testing the game itself, you can recreate this same phenomenon by placing 2 lights on either side of an object like I did here. It’s just an empty baseplate with the new materialservice texture, I’ve also tested it without the texture and found that it still gives you the weird shadow artifact, due to something like the “bloom” or “highlights” created from the light that overlay on the shadow.

The shadows not being there in first person just confirms that shadows are awkwardly rendered in screen-space… it’s weird though because even when I move around and the light “parts” are still rendered on the screen, you still get this shadow bug.

I also think now it’s because of the bloom/speculars overlaying the top of the shadow itself, since the lights are really bright.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.