Internal Way to Quit RobloxStudio Simulation

Hey Roblox,

So I am working on a FPS game, and the camera is locked in first person, so I can’t really move my cursor. Because I can’t move my cursor, I can’t press the “stop” button in Roblox studio. I’ve tried alternate stopping methods, my computer is weird so I can’t do the Shift+F8 shortcut. And something is up with robloxstudio so you can’t open up the esc menu by pressing esc. I’ve tried a solution by making the following script

function scriptA()


but i get the following error

ContextActionService: Unexpected error while invoking callback: The current identity (2) cannot Stop (lacking permission 1)

Any way to fix this?


When I get locked in first person in Studio, I just press the Windows key which unlocks your mouse, and press stop.

1 Like

Yeah that’s the problem…
I’m on a mac :grimacing:

I think the script does not have permission to stop the game.

You can’t do that, it’s clear that scripts doesn’t have permission for using such functions

I don’t know how Mac works, but looking up the windows key equivalent on mac got me this

You can’t quit studio with anything in game, we don’t have permissions to do that. The best you have is doing a keybind or getting your mouse unlocked.

You should be able to stop the game from running in Studio using Shift + F5.

It should be Shift + F5, F5 is the shortcut for playtesting, and Shift + F5 is the shortcut I use when I’m locked in first-person.

1 Like

Hold ctrl + esc or option + esc to open the Roblox Settings UI (I forgot what its called xD)
Idk if this only works on mac

1 Like