Invalid XML on opening a place

Error Information & Id:

I can’t open my place, Yesterday i saved my place and then closed studio and that’s it, i didn’t shutdown my pc in the middle of the save, and now i got this error, i’ve worked many hours on this place and now i lost my progress??

I have removed roblox cache and roblox files using regedit and some roblox files in appdata, but it still didn’t work, i restarted my pc 2 times but nothing worked, there is nothing in version history or roblox saves…

Log/dump files were attached to the internal ticket by a Roblox Staff (@Focia19), due to the sensitive information they may contain, will not be shared publicly!

We’ve filed a ticket into our internal database for this issue, and we will update you when we have further information!

Thanks for the report!

Hi, can you also DM the corrupted file?

Hi, I looked at the file, it is for sure corrupt. In a hex editor, I see nothing but "0"s, so no recoverable data. To be sure this wasn’t an error in file transmission to me, the MD5 hash of the file was fbf2384151ed4b1699943739efb3e33d. Can you run MD5 locally or examine the file in a hex editor (on mac you can use the xxd tool) to see if you see the same thing?

There’s not much to do from a data recovery perspective if this is true, but I’d like to find out if this is a system error on Studio’s part or something local to your system (corrupt filesystem, bad HDD, etc). If you can recall, was there anything ‘special’ about how this file was created? Was it always stored as a local file, or was it downloaded from a cloud file? Did you save it many times, a few times, etc? How long did it exist and you opened/reopened it before the problem started?

I probably closed studio too fast when i saved, but there was still the “studio is closing” notice, and i saved the rbxl file normally, not through cloud file

My MD5 on the same file was:

I reopened many times but not too much, only for few days, i’d say almost 10 times in total, i don’t really remember tho

I used hex editor aswell, it’s all filled with zeros, I guess i’ll start publishing my saves to roblox database so i don’t lose em, I also find it strange that there weren’t extra recovery file of the same local rbxl file, so recovery files only generates on published places ig, but thank you for the answer & help!

(I’ve been working for several days on the file but it’s not like a month work so it should be fine)

Yes, unfortunately not much we can do here. Is it possible it crashed when you saved? The last log file that actually opened the place would tell you this if it was saving while it crashed. I will also follow up on our end to see if there’s anything preventative we can do on our end.

1 Like

Thank you for the great service & help, Also, there wasn’t any crash when i saved, all i remember is that i shutdown the pc after i saved and roblox studio was closed properly, i guess it’s just something with the disk corruption that would rarely happen on pcs, so i guess there wouldn’t be any issues with roblox studio, Thank you!

Storage corruption is exceedingly rare and this is almost certainly a studio issue. I’ve seen multiple cases very rarely over several years of people having their local files silently saved over with null bytes. There have been no obvious patterns to this as far as I could see.

You should package up all of the log files from the day you saved this file and this happened, and send them to staff to be sure you’ve included the one where the issue occurred. Ideally only the one from the session you saved the file last though, if you’re able to find it.

Crashes can happen silently, if they happen during closing, its very hard to tell. It’s best to check your logs on this.

Hey there,

I had a similar problem. Only that my power went out, now usually stuff like that would be normal since my place can boot back up but as of today, well, it had that same issue pop back up including for a recovery save that was as recent as last night when the power went out.

So I did some digging and eventually was told to try SFC /scannow using cmd which I left running. Do you think that can solve the issue? If not could I send you the file or will that waste your time?

If it is a waste of time and the scannow prompt doesn’t “find” any errors, then no need to worry since I lost a couple assets that I can easily redo and probably get it to its former glory the best I could. But if it isn’t a waste of time to send it over then I appreciate it. I’ll get back to the SFC command I tried when I get back to my PC in a few hours.

Hi all - not much more we’re going to be able to do here. I will leave this link to a similar problem which resulted from a place version being saved with an unsupported browser extension. (This is just for folks finding this bug after searching for the error, not saying this was a related cause here). We can reopen if we find a case with more info on how the error occurred, but for now there’s not too much more to go on.