Inverted scrolling direction on mice without horizontal scrolling in the Roblox game client on Mac

On macOS, there is a setting called natural scrolling which when enabled, it inverts the scrolling direction so that moving the mouse wheel up will scroll down and moving the mouse wheel down will scroll up. This setting has been enabled by default since OS X 10.7 Lion and applies this behavior to all the applications on the computer. But on the Roblox game client, the natural scrolling is always enabled on all trackpads and mice that support horizontal scrolling like the Logitech MX Master 3 or the Apple Magic Mouse and natural scrolling is always disabled on mice that don’t support horizontal scrolling instead of following the system setting.

This behavior happens every time in the Roblox Player application on macOS, the natural scrolling always follows the system setting in Roblox Studio.

To reproduce this:

  • you need a trackpad or a mouse that supports horizontal scrolling and a mouse that does not support horizontal scrolling
  1. Go into System Preferences > Mouse and make sure that the “Scroll direction: Natural” option is enabled.
  2. Try scrolling in a system application such as a webpage in Safari, both mice/trackpads will have the natural scrolling behavior.
  3. Now try scrolling in a Roblox game, the mouse/trackpad with horizontal scrolling will have the natural scrolling behavior while the mouse without horizontal scrolling will not have the natural scrolling behavior.
  • Try steps 2 and 3 but with the Scroll Direction: Natural option disabled, both mice/trackpads will follow the system setting outside of the Roblox game client but the in the Roblox game client, the mouse/trackpad with horizontal scrolling will have the natural scrolling behavior while the mouse without horizontal scrolling will not have the natural scrolling behavior.

YouTube videos of this bug

  1. Inside Roblox Player with natural scrolling enabled:
    https://youtu.be/UWQcvy-Ik_g

  2. Inside Roblox Player with natural scrolling disabled:
    https://youtu.be/3MwN2rrAQLM

  3. Outside Roblox Player with natural scrolling disabled:
    https://youtu.be/loZ5nxjOpCg

  4. Outside Roblox Player with natural scrolling enabled:
    https://youtu.be/tJJndeiL6rk

Mice/Trackpads that I have tested this with:

Mice without horizontal scrolling: Logitech wireless USB mouse (unknown model number), Dell M-UAR DEL7 USB mouse
Mice/Trackpads with horizontal scrolling: Apple Mighty Mouse (Model A1197), Apple Magic Mouse (both 1st and 2nd generation), MacBook Pro 13-Inch (Late-2013) Internal Trackpad, MacBook Pro 13-Inch (Mid-2018) Internal Trackpad

The specs of the systems that I have tested this on:

  • MacBook Pro 13-Inch Retina display Late-2013, Intel Core i5-4258U 2.4GHz dual-core, Intel Iris 1536 MB, 8GB RAM, 256GB SSD, macOS Mojave 10.14.6 (18G103)
  • MacBook Pro 13-inch Touch Bar (Mid-2018), Intel Core i5-8259U 2.3GHz quad-core, Intel Iris Plus 655 IGPU (1536MB VRAM), 8GB RAM, 256GB SSD, macOS Catalina 10.15.5 (19F101)
4 Likes

I cannot zoom in with my apple mouse it just changes the camera direction and im really angry

1 Like

I am in the process of checking over bug reports and following up on some bugs that haven’t received any activity in a while.
Is this issue still occurring or can you confirm that this bug has been resolved?

1 Like

This issue is still occurring. I am able to reproduce it on the 461 release.

1 Like

I’m able to reproduce this on other operating systems too.

1 Like

Thanks for the info. When there is an update i will pass it on.