Invisible part in mesh and union

Hello. I’ve been working with region3 trying to make different sound environments. I’ve found that in this union (and later mesh) there is a invisible part (highlighted in dark blue in the pic below). I’ve tried to convert the union to a mesh but the problem still exists. Any way to fix this while still having this as a single object?

1 Like


I suggest you reload your assets.


Didn’t work. Still the same thing happens.

You could try setting the CollisionFidelity to PreciseConvexDecomposition. Try that out, see if it works.


Did you tried reloading Roblox studio? I usually have the same problem when I’m unioning parts in a place that has team create. Closing and reopening studio always fixes the problem for me. I hope it will work for you too.

Unions and MeshParts do not calculate collision geometry very well for concave/convex angles. Using the Collision Fidelity property set to PreciseConvexDecomposition as @Verphos suggested works, but too much of it can create needless performance loss. If a situation does not need MeshParts or Unions, using Parts is usually better, but only if players are ever going to collide with those Parts.

Also @Lv100DominusUltimus please stop putting “Feedback” in front of every single post you make when there’s literally no point to doing so. When you aren’t even giving feedback (like your post above where you’re suggesting alternatives) it makes it look odd and confusing.


Nope, didn’t work. But thanks for attempting to help.

3 or 4 times already, does nothing :confused:

I’ve tried with multiple parts but the way the script works the sounds start to overlap. So this isn’t an option.

Maybe this will help.

How to recover invisible / corrupt unions