Is it normal to have this many instances? (the map is quiet lagging too)


147k is pretty insane… I suggest optimizing your game so you’re not using as many parts. If that isn’t going to work then use a part unloader. You can use Roblox’s streaming enabled property to do that (click Workspace and then set it to true).

Use streaming enabled and you’ll be good to go, I see most games having MILLIONS of instances so don’t worry. Just properly optimize things.

i already turned on streamingenabled. its doesnt lag on roblox but it does to be pretty laggy on roblox studio. any solution?