Is it possible to link VSC to roblox studio on macOS?

Hi everyone! I want to ask whether I can link VSC to roblox studio. Roblox studio is super unstable for me on mac, and it is impossible to code without have the studio crash, or having the delays when I type it in. (By delays it means it takes 2-3 seconds to show the code I type)

I want to link VSC to roblox on mac. I’ve tried Rojo but it doesn’t work.

Is it impossible to link VSC to roblox studio on mac, or I’m using the wrong method. Help would be appreciated, thanks! :slightly_smiling_face:

I tried figuring out how to do this at around this time last year and after numerous attempts couldn’t find anything that worked. There’s not a way to do this that I know of (except downloading a copy of Windows and partitioning your disk) but there may have been new options created in the past year that I haven’t heard about.

I’m asking because I was watching @MrAsync 's stream and noticed he’s using VSC to code as well, but he’s on MacOS, which surprises me as I’ve tried to connect VSC to roblox studio multiple times.

Do you mind linking the stream?

Yeah, it’s possible, you sure you did the setup correctly with Rojo 0.5.4?

Hey can you show me how to set it up? I just downloaded the VSC rojo plugin, and the rojo plugin on roblox. Here.

I think you mean extension.

Anyways make sure to click start Rojo on the bottom right of the vsc, it’ll do everything for you.

There’s an error, “Command ‘Rojo: Initialize’ resulted in an error (Running the contributed command: ‘rojo.init’ failed.)” and “Couldn’t install latest Rojo: an error occurred while compiling the latest binary.”

Hmm, make sure to install cargo according to the setup:

Windows, or
macOS with cargo installed

From the marketplace of vscode.

I use an M1, with Rojo 6.0.2, kind of a double trouble since the M1 isn’t totally compatible with studio yet, and cargo is buggy. However, I didn’t have too much trouble setting it up. Not sure how that helps but it is possible.

1 Like

It returns ‘build failed’ after I run Rojo:Initialize though… Not sure why that happens-

Did you install cargo?

Yes I did. I installed it and ran rojo:initialise, but it still didn’t work.

Did you install rojo using cargo according to the setup in the documentation?

Make sure the version of rojo installed is the same as the plugin within Roblox studio.

–In the terminal

cargo install rojo
cargo install rojo --version ^0.5

Yes I did. It’s sooooo painful fixing this lol. I’ll send the errors once I get on my laptop

It says “aborting due to previous error”.

Have you tried google searching the all the errors that occur during the installation process? For example for this error message I found this GitHub post:

The solution here appears to be to reinstall cargo which seems worth a shot.

Can you try

~/.cargo/bin/cargo clean
~/.cargo/bin/cargo build --release --verbose

But yeah that’s how you solve error messages within the terminal, just google em.

Yep but rn it returns " error : could not find Cargo.toml in /Users/XXXX or any parent directory’
Will carry on trying…

Update: Still doesn’t work after I reinstalll cargo.