Is it possible to prevent the default flinging / falling down onto the ground?

Not sure if you’ve seen this before, but Roblox has this annoying system where your character can fling if there’s a huge amount of force applied it or if your character collides onto an object, they suddenly fling to the ground and stay in that state for a couple of seconds (I used to think this was the result of platform stand being activated to true in the character humanoid, but that isn’t what’s actually happening here).

Here is an example of what I mean (such as you are running with very high speeds and collide to a wall):

My main problem here is this sudden flinging and then the character staying fallen on the ground for a couple seconds.
I would honestly appreciate it if anyone can provide a solution for this as it makes many games that repeatidly use forces or high walk speeds very tedious to play.

1 Like

Try referring to this page

1 Like

So by exploring that, I’m assuming the states - Ragdoll and Falling down need to be set on false, and GettingUp on true?

script.Parent:SetStateEnabled(Enum.HumanoidStateType.FallingDown, false)

script.Parent needs to be the humanoid

1 Like

Ah got it, thank you for that. Also would it be best to loop it?

Disable the Ragdoll humanoid state, fallingdown humanoid state, and probably physics state.

1 Like

No, it just needs to be set once, put it in the StarterCharacterScripts

Or u can use this

	t.Character.Humanoid:SetStateEnabled(Enum.HumanoidStateType.FallingDown, false)
1 Like

Right that works nice, thank you all for the solutions.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.