Is there ROBLOX Blender plugin working?

Howdy, thank you for tuning in.

So, let’s get to the point.
I recently installed blender 2.8 and 2.9 along with the plugin for blender (the roblox plugin for blender)
I animated a default R6 rig and clicked the export button that copied the key frames. I then went inside of studio, got the R6 rig, activated the blender plugin for ROBLOX and clicked import animation. I pasted the key frames into the script and then the text “Animation Loaded” appeared on my screen BUT the animation was not playing. I tried using different rigs and animations (as well as different versions of Blender) and still no success! If anybody knows if this is just an error on my part or something broken please let me know, been trying to do some animations and can’t get them imported.

Thanks for reading,


It appears perfectly functional to me, can you send me the plugin you are using.

1 Like

This is the ROBLOX Blender plugin i’m using.

This is the Blender plugin I am using to build the rig and export the animation


1 Like

It’s working for me, might be a technical issue on your side or something you missed.

Seems more like a blender issue to me. Refer to: Community —

They have a pretty helpful community, and could probably help you more than what I can do here.

1 Like

That’s the thing I don’t know if it a blender problem or a ROBLOX problem. Like I don’t know which side isn’t working properly.

1 Like

As far as I’m concerned, it was working for me a month ago, and ROBLOX didn’t change their animation system drastically, so I’d say its probably a technical issue about the plugin, or how your using blender.

There are many roblox developers in the Blender community as well, it wouldn’t hurt to ask in their Discord.

If you can’t do any of those, try to reinstall both blender and the plug in.

1 Like