Is this a user error or engine bug? - Rigging / Motor6Ds

If you’re able to answer this or provide guidance, thank you very much!

THE ISSUE: If I try weld the HumanoidRootPart to any of the body parts, it moves the entire rig, however if I try use a rig editor plugin (as seen in the screenshot) they seem to retain the original position somehow? This makes my use of ragdolling extremely complicated.

SOLUTIONS TRIED: I’ve tried using other constraint types, however, due to the way Roblox rigs work anything besides a motor6D breaks the rig (all animations will no longer be played/playable)


  • I’ve rigged this using a rig plugin
  • If I remove the Bones from HumanoidRootPart, the parts return back to normal

ReproModel.rbxm (248.2 KB)


Any questions please ask, included the model if anyone wants to try out, if it’s a bug I’ll delete this and move to the bug-reports category

1 Like

I have the same problem with welds… they always move the parts to the position of the Part0 and it’s soooooo annoying. But im curious if there is a problem with using a rig editor?

1 Like

The Rig editor I’m using is just to preview stuff, all I’m simply doing right now is welding HRP to any part of the main body.

1 Like

(bump) If anyone knows, help would be appreciated!

1 Like