Is this problem from roblox? Can't figure out what happens

Im having a lot of lag in the studio (in a specific place) the last days, (specially when i use the Scale Tool)

This is becoming a huge annoyance for me…

I have recorded a video of the output spamming the same message without control, wich is maybe generating the big lag: C__Users_camilob829_3D Objects_New_RB_Maps_MTEST.rbxl - Roblox Studio 2020-11-10 19-29-32

Ways to finish with this?

Thank you!

1 Like

Are you using just the Roblox Scale tool?
It looks like you are getting messages from other Plugins too. Try turning off all your plugins to make sure it isn’t one of them that’s causing the issue.
I’ve never seen a Model.GetPrimaryPartCFrame error while using the Roblox tool.

I wasn’t using the tool during that, the studio automatically started poping out thoose messages

Maybe i should disable F3X tools…

Woah what the heck is happening! It seems you have a rogue plugin. Do what Scottifly said and try the process of elimination. Looking at the error it seems that you have some sort of building/modeling plugin that’s doing this. Did this happen when you first opened up studio? Did you run a command that could have caused this? Also, what is up with that cursor; looks great!

1 Like

I disabled lots of plugins now, i also uninstalled F3X

No, this only happens in a specific place file

Grass removing command, maybe?

Maybe this can help:

@Paradigmed Any ideas?

Seems that he changed the texture files, easy to do, dm me if you want to know how, dont want to spam, and im having a feeling it might be F3X, which is a common plugin. Ive gotten this error too, dont know how i fixed it, I just started pushing buttons.

1 Like

Could you upload a copy (You can DM me it or post it publicly)of this place and list the plugins you have so I could replicate the steps? If possible could you also add in the grass command?

Any chance you used a free model that might have been corrupted and added a script hidden somewhere in your place?
You should check all of your folders, not just the ones in Workspace.

I haven’t inserted models there, also i have an antivirus

I disabled every plugin that i have, but it still dropping the same error

Just if someone runs intro the same problem

I finally solved this, this entire time there was a humanoid inside the workspace :man_facepalming:
ALSO, i solved the output spam, basically i set a PrimaryPart to the workspace, and then the output stopped spamming, i ever used the workspace without a PrimaryPart (i think output shouldn’t spam that message), but this seems a weird fix for this

I mean:

1 Like