Issue with making character massless / weightless with my carry script
I have this carry script (which welds 2 players together) and for some reason carrying makes the person slower and unable to jump at times. Why is this? I set every basepart inside the player being carried to massless and I get the same result. Any solution?

Whenever I sink into the floor in the gif I am trying to jump. The script seems to work fine except for the fact that when you carry someone it weighs you down. I made all the parts inside the character being carried massless. Any solutions?

Have you tried changing the NetworkOwnership of the other player’s character to the player carrying them until they set them down again?

1 Like

how would I go about doing that? looping through every basepart and setting network ownership?

Here’s an article on Network Ownership, not sure if it fully answers your question for this. But I believe so.

1 Like

No luck. I set networkownership to every basepart on the player being carried and nothing seemed to change.

Then I’m not really too sure what would fix it as I haven’t personally done something like this before. That was just the first thing that came to mind when I saw it.

1 Like

Yeah I understand. I thought the network ownership would’ve worked too.
Thanks for trying.

1 Like

Sorry I couldn’t be of more help.

1 Like

I had this same problem with my chickens, I fixed this by removing the humanoid in the thing your carrying. Not sure if this is the best solution for your particular case, but tell me if it works.

1 Like

Thats not really a viable option for me unfortunately. But that does make sense since I can weld parts to the player without a problem it has to do something with the actual humanoid. But what in the humanoid is causing it?

Does the other player have their Player.Character still set?
I believe that as long as a the person being carried has their Player.Character set, it’ll always keep that player’s network ownership, unless the weld was made server side, etc for both players to use.

Maybe use a localscript on the person carrying another player to set the other player as massless and cancollide false with a renderstepped awhile carrying?

1 Like

The weld is server sided and unsetting the plr.Character would break a lot of stuff so I’d rather not try that lol.

I could try setting the carried player massless on the client rather than the server and see how it goes.

setting it on the client yields the same result.
All I know so far is that the issue has something to do (most likely) with the actual humanoid since thats the only difference from other models I have welded to the character that work fine.

setting the humanoids platform stand to true (on the server) fixed the issue.
ty to all who tried their best to help.