Issues with coupling monorail using Body Velocity


I am trying to create a monorail with two carriages where the first one is powered with a body velocity chassis. However, I am not able to join the two carriages without causing the monorail to be unable to move when driven.

I have tried using rope, rod and hinge constraints but they do not work and cause the monorail to be unmovable when driven. I have switched between multiple body velocity train systems but it seems like there is no way to couple the train if it is using body velocity. Only by setting the second carriage to be massless, then the monorail is able to move but the second carriage flings about and shakes as the monorail moves. Both carriages are unanchored.

I do not want to weld the entire vehicle together as it makes it look unrealistic around track corners.

I have searched for this issue but I only found a similar post without much context and has been unanswered for over a year.


Monorail is unable to move when coupled using constraints

Chassis I am using to power the front carriage

The monorail
It is made up of multiple mesh parts and parts and some are massless to allow the train to move properly.

Here is the place where I need to link to join the two carriages

Is there any way to couple the monorail, or is it advisable to switch to normal vehicle wheels to drive the monorail (I don’t really want to do that because it isn’t that smooth). Also, is there a way to control the chassis velocity of the second carriage separately without it being connected?



Have you tried using a VectorForce | Roblox Creator Documentation in each carriage with a HingeConstraint between them?

The VectorForces should be able to be applied in both carriages.

1 Like

I tried to do what you suggested on two parts, is this what is supposed to happen? I’m not very good at this kind of thing

The parts move together when dragged and both moved together when a body velocity was inserted in one of the parts. (edit: I realized that was because it was hinged)

I may have done this wrongly, could you please guide me on this?

edit: what I did doesn’t have any effect on anything, I don’t think the vector force is doing anything

The alternative to BodyVelocity is LinearVelocityConstraint.

I have had problems getting constraints to work. However, I also know that BodyVelocity are not as good as LinearVelocity in terms of customisability.

2 BodyVelocity do not work on 1 assembly however you can get 2 constraints to. Also with constraints you can set their Force relative to an attachment of your choice too.

I recommend a linear velocity constraint on the front of the train have the trains connected by hinges or ball sockets and make the track smooth. (Make aue you have an attachment set relative to itself and not the world that way it will move forward always relative to itself)

I am not entirely sure there are docs on the hub about this but you can check.

Hope this helps.


Thanks for the support, I continued experimenting for a bit before I was about to give up on using body velocity, then I discovered that I could attach a rope/rod constraint to an ordinary default part to the back and it was able to pull it. I’m not entirely sure why it didn’t work for the almost massless second carriage model though. I’ll see what I can do to fix it.

This is ridiculous. The entirely massless second carriage cannot move at all even when pulled by the monorail.

Property massless is enabled for every part in the second carriage model

I’ve tried using (non-massless) parts to represent the second carriage and they are able to be pulled by the monorail, yet the completely massless second carriage model cannot even budge.

Here is a video of an example of how it should pull the second carriage
Pink parts represent the other meshes that would be in the monorail (massless)
The grey part is the one with mass

I adopted this similar method when using the real object but it doesn’t seem to be able to work

As you can see it is able to move the “second carriage” forward and backward

Does anyone have any idea about what could be causing the thing to not work?

I redid the entire second carriage chassis and ensured I didn’t forget to make some things massless. I probably left some seat parts in the model still containing mass which caused it to be too heavy. It is now able to work.

To couple the carriage, a rod constraint worked. All I needed to ensure was that the second carriage was not too heavy.