Items Showing Up Weird When I Try to Render an Avatar

Right now I am trying to use Blender to render something using SabrinaBrite’s avatar. When I import her avatar, the swords on her back and the smoothie in here mouth don’t have a proper texture. The same thing happened when I imported DJ’s avatar. The swords didn’t have the right texture either. How do I fix this?

1 Like

Try importing separately so they have their own texture might be glitching cause of the texture size if you don’t know how to do separately just reply back and ill help.

1 Like

That happens because the swords use that “cartoony” effect, the same as the milkshake. You will need to add it by yourself, because afaik there’s no way to import that effect from studio to blender


@lionslunchtime104 and @DavidNet22 You are able to actually,
Go to edit mode, then go to the menu I have open. Near the bottom, select ‘Backface Culling’.

This cube with inverted faces is now able to be previewed the same as it would be in Roblox.

To render:

Assuming you have the latest version of Blender (not 100% sure of when it was added), go to the Material Properties tab, then go to Settings, then enable Backface Culling.

Now, you’re able to render the objects as expected!

Best of luck with your projects! :slightly_smiling_face:


Thank you, that’s what I said, he need to make his own backface and not just import it, but that’s a helpful response :slight_smile:

1 Like

You can actually just import it. As long as you’re using the texture that was used when exporting from Studio, you can enable the backface culling property in the material properties tab, then it will give the desired effect.

1 Like