[Jailbreak] Can no longer rob the Cargo Ship with Ropes in Public Servers

Screen Shot 2021-01-11 at 3.52.40 PM

How it should work: The Cargo Ship in Jailbreak appears every 10 minutes or so, with a loud horn across the server when it’s entered. Criminal Players need a helicopter to rob the crates from the ship. By pressing the rope button, they have to skillfully hover over a crate and grab it without being shot down.

The Issue: When your progress bar for grabbing a crate reaches 100%, the crate disappears instead of being grabbed. No errors appear in the console.
The robbery works as intended in private servers but not public servers.

Video: https://www.reddit.com/r/robloxjailbreak/comments/kv51j5/the_containers_work_in_mysterious_ways_too/

Appreciate any insight on what may have happened! We’re not sure what went wrong.


Are you certain that it disappears, and doesn’t get teleported / glitches out somewhere else?
Is it possible to test if this happens within Studio testing?

On top of this, is there any correlation between this bug’s appearance, personal game updates, and roblox engine updates?


Hm, this is strange, Has it been tested on other devices or is it just a mobile device thing? In the video, the device is mobile, could possibly be a mobile bug.

If not that as @Sirian142 it is important to see if the it gets teleported somewhere else. But after watching the video multiple times, it seems like it could rather a performance issue than an actual bug as playing the game for some time ropes tend to lag a lot and glitch everywhere on lower end devices and could be the problem for this situation.


We know it is not a mobile bug, this is because the graph provided. It shows GLOBAL cargoship robberies, which means all devices are most likely having this issue too. It doesn’t have to do with performance, because again; graph and on top of that performance of that issue would have to be server sided.

Almost everyone is having this issue, and for some reason it only occurs in public servers.


19 posts were split to a new topic: Off-topic Jailbreak issue replies

I think Jailbreak developers would appreciate it if we kept this topic for them and Roblox engineers to communicate – guessing what the problem is doesn’t help and you’re actively making it more difficult for them to communicate with all the off-topic comments.

Definitely all devices for this bug.


This part is intriguing and might be able to lead us to the issue. Based on this, I would have two questions that you can answer or look into on your own:

  • What differs between your game’s application logic in public servers versus private servers? Are any features disabled? It could be something that doesn’t seem related.
  • Does it happen on brand new public servers? (I ask this because it is possible that, if you’re only checking older public servers, there could be some sort of event taking place in the server that causes this after it has taken place)

How do you connect the RopeConstraint to the crate?
I made a simple repro in Studio where I have a block fly over another, and when it detects it underneath, it sets the RopeConstraint's Attachment1 to the Attachment in the crate and it works normally.



Repro Script
--// aaa
local Part = script.Parent.PrimaryPart

function Raycast()
	local result = workspace:Raycast(Part.Position, Part.CFrame.UpVector*-100, RaycastParams.new())
	if result then
		local instance = result.Instance
		if instance.Name == "Box" then
			return instance

while true do
	script.Parent:SetPrimaryPartCFrame(Part.CFrame - Vector3.new(1,0,0))
	local result = Raycast()
	if result then
		Part.RopeConstraint.Attachment1 = result.Attachment

According to the graph it looks like it broke around the same time this feature went live: [Activated!] New Part Physics API


Should be unrelated, especially since there is this public/private server difference. But I can try with the feature turned off if I get a reliable repro.


@asimo3089 For me, it worked perfectly on public servers before the winter update. Now, after the upgrade, on the other hand, it’s harder to grab the box (sometimes randomly starts to grimace and then falls off) But I think the wait time can be something (wait () or delay ()). There was a similar problem in my game when I made an automatic vehicle, but the player interaction was too buggy.


It could be a mobile device error. For me, the terrain will discolor and there will be purple stripes on it (Jailbreak, mobile device). Have you tried asimo on other devices (pc, other mobile, or tablet). Anyway, it’s a pretty interesting problem. Is it Server or Client side?

1 Like

I noticed this happening the other day when I went to rob the cargo ship as a cop in a public server and I noticed that the crate disappeared every time I picked one up and I looked at the developer console and there were these errors from this script named “CargoShipCoordinator”. When I tried to rob it yesterday in a public server after I saw this topic, I did not see any errors in the developer console from this script and the cargo ship was still not working in that server but it worked fine in my private server. The vehicle towing with helicopter ropes which uses a similar system to the cargo ship robbery seems to work perfectly fine in both public and private servers.

Here is a screenshot of the developer console errors that I got from the other day:

The error seems to be coming from a script named “CargoShipCoordinator” which is in “ReplicatedStorage.Game.Robbery.CargoShip” on lines 76 and 80 and also in a LocalScript in StarterPlayerScripts on line 30.


Out of curiosity, is the crate robbery only working for the first client to connect to the game?

The reason I’m asking is because I’ve faced a bug recently that for some reason only the clients other than the first to connect to a server experience (Equipping Tool w/ CollectionService tag removes the tag on clients other than the first to connect to game).

This might explain why the issue only occurs in public servers since you are not the first to connect if you are joining an already existing server.


Is the cargo container anchored?

So this is odd! Maybe an engineer in the background did something because we haven’t updated the game yet.

Cargoship robberies had an increase on January 10th, with steady increases up until
January 16th where it returned to normal. We didn’t change anything on our side so to whoever did, thank you so much! I was surprised to check the charts today and see it back to normal!

I’ll wait until making posts in the future until we have a proper easy repro file. I was hoping it was a simple flag change with ropes that would be easy to catch. Thanks again!


Hey hm, this post could be useful, he made like 2 bug reports on one, I’m referencing the second bug which he marked as resolved, it has something to do with network ownership and welds, it could be that; Update 460 broke several key features in my game

I’m not 100% sure about that since I DO NOT know how your scripts work at all this was just a similar bug report which was also posted in about the same time; and also resolved in about the same time too;


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.