Jailbreak Cargo Plane invisible on Xbox

We recently added a Cargo Plane robbery to Jailbreak. For some reason Xbox players can never see the plane but they can walk on it. I’m not sure if this is a limitation or a bug, we’ve had this issue since Day 1 and it’s not an issue on any other platform.

Cargo Planes spawn around every 10 minutes in servers. Playing on Xbox, the plane should be invisible. At the airport, you’ll notice other players hopping in or around the plane but nothing is there. I’m not sure if you can hear the plane coming.

Thank you!

13 Likes

Hi @asimo3089, we’ll look into this. Is there anything special about the cargo plane?

4 Likes

I can’t think of anything unique we’re doing with the plane vs our trains. As far as I know, this is the same system our trains use and those appear fine on Xbox. We did have some velocity setting issues on the xbox trains in the past but we solved that a while ago.

I’ll tag @badcc since he programmed the planes. We’re both not sure why only Xbox is giving us trouble. Normally we’ll find a workaround for issues like these!

5 Likes

Would it be possible to make a test place that spawns the plane fairly often? Something that would also be easier for us to inspect the Lua of?

Something I would be able to put a local script in myself and print whether the plane exists on Xbox at all would be helpful.

EDIT: Lets move this discussion to the PM.

2 Likes

Hey asimo!

I’d like to tell you that Xboxs can not walk on the plane.
Tried to make my Xbox friends rob it with me, they didn’t see it, they couldn’t walk on it. The best they could do is jump on my head.

Hope I helped!

1 Like

Hello, i want to say that I was able to see the plane in the sky floating, I mean, I guess the plane track is made by parts, and the plane follow those parts, well, the plane gets freezed in the last part of the track. What I want to say is that I can see the plane, but not how expected.

Sorry by reactiving this thread

The issue has been found and will hopefully be fixed in the upcoming months.

the issue has been found, what took it 22 days to find it? was it on roblox’s end?

1 Like