Jump Button and Thumbstick sized & positioned wrong in mobile emulator


iPhone 14 Pro ^

To reproduce, set your studio emulator to any phone and run play solo.

The mobile UI elements (jump button, thumbstick, dynamic thumbstick) are way too large on phones. They’re being sized as if the device was a tablet. This started happening maybe a day ago? Maybe after the last release. I went inside the TouchJump module and added some prints to see what’s going on

local minAxis = math.min(self.parentUIFrame.AbsoluteSize.x, self.parentUIFrame.AbsoluteSize.y)
	local isSmallScreen = minAxis <= 500
	local jumpButtonSize = isSmallScreen and 70 or 120
	-- roblox code ^^

        -- my debug code vv
	local parent = self.parentUIFrame
	print(parent.AbsoluteSize.x, parent.AbsoluteSize.y, isSmallScreen)
	parent:GetPropertyChangedSignal("AbsoluteSize"):Connect(function()
		print("changed to", parent.AbsoluteSize)
	end)

and what appears to be happening is that when the PlayerModule scripts are running, the TouchControlFrame is one size, but then changes size immediately after the mobile elements are created.
image

So this phenomenon happens on every emulated device, not just phones, but it’s noticeably a problem with phones because the mobile UI elements get sized way bigger than they should be for that device size.

Beta features I have enabled:

  • Aerodynamics
  • Assistant Preview
  • EditableImage and EditableMesh
  • Faster Play Solo
  • Grass Length Customization
  • In-experience CSG Improvements
  • Luau Native Code
  • New Audio API
  • Notched Screen Support
  • Notification Overhaul
  • Terrain Editor
  • UIListLayout Flex Features
  • Updated Roblox Controls
  • Upgrade Shorelines
  • Video Uploads

Reproduction file isn’t needed since this happens in an empty baseplate, and the code that handles creating the jump button & thumbstick is inside roblox’s PlayerModules

Expected behavior

The mobile UI elements (jump button, thumbstick, dynamic thumbstick) would be the correct size for phones, such as jump button being 70px instead of 120px

8 Likes

Thanks for the report! Are you still able to reproduce this issue? I tried this on a Mac and I could not get the emulator to show large buttons. If it is still happening, can you post the specs for your computer and the monitor? Thanks!

1 Like

I’m not the OP but I can also confirm this issue is still happening:


My specs:

Computer:
Windows Version 22H2
Processor AMD Ryzen 7 5800X3D 8-Core Processor

Monitor:
Resolution 2560 x 1440
165Hz

I don’t know if these are all the specs you need, if that is not enough reply to my message and tell me what else is needed.

1 Like

I can confirm this is happening. I have tried this on different places and i get this behavior in all of them.

As i was filling this out i was goint to say this this happens in every place, but now im experiencing behavior that sometimes it works as intended in certain places where it used to be bugged but is now consistently working as intended in this place only.

system information:

Windows 11 Vers. 22H2.
AMD Ryzen 9 5900HS with Radeon Graphics
monitor: 1440p 165hz

This is happening for me as well and disabling beta features doesn’t fix it.

Studio Version: 0.614.0.6140412 (64bit)
GPU Driver: 31.0.15.5161

OS: Windows 10 V22H2
CPU: Intel 13600k
GPU: Nvidia 3060ti
Monitor: 2560x1440p 165hz

Thank you for the report. Based on our testing, this appears to be related to the faster play solo beta. Does disabling that beta mitigate the issue for you?

2 Likes

Yep, it seems like when I disable the faster play solo beta, it behaves as intended

2 Likes

Thanks again for the report, we have identified the problem and prepared a fix which will ship with a future studio update.

4 Likes

This should now be fixed; touch UI elements should now be the correct size in the emulator after a studio restart.

3 Likes

Hi,

I’m getting this issue again. Seems related to the faster play solo beta, the same as last time.

Thanks.

1 Like

I can’t reproduce this in my own testing, could you post what beta features you have enabled when you see the bug?

Another possibility is: the fix was implemented in the PlayerScripts (specifically the ControlModule, see the code guarded by FFlagUserResizeAwareTouchControls). If your game overrides these scripts, you will need to incorporate the fix into your forked version.

1 Like

Thanks for the swift response, yes the issue seems to be that our ControlModule is outdated.

Much appreciated.

1 Like