Jump button dissapearing after jumping on mobile?

(I did not know what topic to use, so excuse me for that)
The mobile jump button disappears after pressing it.
I do not have any code messing with it and i can confirm, i have looked through the whole games scripts (ctrl+shift+f), nothing is interfering
3. What solutions have you tried so far? Did you look for solutions on the Developer Hub?
I tried changing the movement type on starterplayer (Devtouchmovement)

1 Like

Have you tested it on a physical mobile device or tried to restart studio?

It may be a studio bug.

1 Like

It is not a studio bug, i have also tried it on my phone. Its not a studio bug it is a mobile issue

1 Like

Ok. I am sorry I am unable to help you!

Go look and have a nice day :slight_smile:

1 Like

I am bumping up this post as I am having this exact same issue. I’d very much appreciate if someone has a solution to this, and if I find one I will reply back with my solution.

1 Like

Replying because I have found a hacky solution to fix it, I have no idea if this will always work because I’ve never done mobile development before

if not game:GetService("UserInputService").TouchEnabled then return end

local Player = game:GetService("Players").LocalPlayer
local PlayerUI = Player:FindFirstChildOfClass("PlayerGui") or Player:WaitForChild("PlayerGui",100)
local JumpButton = PlayerUI:WaitForChild("TouchGui",100):WaitForChild("TouchControlFrame",100):WaitForChild("JumpButton",100)

JumpButton.Visible = true
	if JumpButton.Visible then return end
	JumpButton.Visible = true