JumpPower 0 doesnt stop jumping

You can write your topic however you want, but you need to answer these questions:
I am trying to make a fun admin command
But when setting jumpPower to 0, I can still jump, but I also added 0 walkspeed, and that worked.

I dont feel like I need to include code.

Please help, Thanks!


Are you sure jump power is being set to 0

1 Like

Yes, I am sure, I am working on making the video work

  1. Check if you are really setting the players jump power to 0.

  2. If that doesn’t work check if StarterPlayer->CharacterUseJumpPower is false, if so set it to true.

  3. Finally if none of these work then check to make sure a different script isn’t setting the jump power to a different value.


Check off one

For two, I am making it work for one player, temporary.
You will see what I mean in the video

For three: I made all scripts, and I know nothing is messing with it.

Just checking, do you get any errors from your code?

Another option could be to just anchor the character’s HumanoidRootPart.

1 Like

I don’t want to anchor the player, because I would like the effect of the player dying after the train goes by.

Also no errors.

Alright, and the walkspeed code works?

1 Like

The walkspeed code works.

character.Humanoid.WalkSpeed = 0
character.Humanoid.JumpPower = 0

The only thing I can think of then would be that you aren’t using JumpPower, but rather JumpHeight. Try adding this code right before the JumpPower = 0 part:

character.Humanoid.UseJumpPower = true

Let me know if that doesn’t work, but I am honestly confused if that doesn’t work :confused:


I just tested setting the walkspeed and jumppower and both seem to work fine so I have no idea what the problem is.


Surprised that worked! Thank you, I never known that was a thing!

1 Like

No problem! Glad it got fixed :wink:

1 Like

You can also go to Explorer → StarterPlayer then in the Properties tab, make sure CharacterUseJumpPower is on.

1 Like

This worked! they should make that more obvious on their documentation.

In game settings / world, you can set it to Jump Power … then all jump power calls work fine.