Keep getting an HTTP 403 (Forbidden) error?

Alpha Force - Roblox

When I try to teleport to my game, I keep getting errors. I get the HTTP error while using the reserve derver function. The error code is from when testing on roblox.

I am using a server script in serverscriptservice. I got my ID from my asset manager. I own both places and my HTTP requests are enabled.

Here is my server script.

local teleportService = game:GetService("TeleportService")
local ReplicatedStorage = game:GetService("ReplicatedStorage")

ReplicatedStorage.RemoteEvent.OnServerEvent:Connect(function(Player, Code)
	local ID = teleportService:ReserveServer(Code)
	teleportService:TeleportToPrivateServer(Code, ID, {Player})

Here is my local script

local ReplicatedStorage = game:GetService("ReplicatedStorage")
local ServerScriptService = game:GetService("ServerScriptService")

local event = ReplicatedStorage.RemoteEvent

Please respond, thank you!

Did you disabled the new security features that prevent game to teleport users in another place?
(It’s under your settings on the Roblox Studio App)

*Hey here I just realised what was the code, you can’t teleport someone to a private server if you don’t create it before, See TeleportService:TeleportToPrivateServer

Exemple from the docs :

    local TS = game:GetService("TeleportService")
    local Players = game:GetService("Players")
    local code = TS:ReserveServer(game.PlaceId) -- Returns a code
    local players = Players:GetPlayers() -- Get a list of all players
    TS:TeleportToPrivateServer(game.PlaceId,code,players) -- Actually teleport the players
    -- You could add extra arguments to this function: spawnName, teleportData and customLoadingScreen

It this it, if so all are enabled.

I did reserve the server in my code though?

Hey, sorry, you indeed created them, I got lost because of the name code used as the placeID and ID used a the server code. Is this error only appening inside Roblox Studio or on the Roblox Client too?

When I play on roblox, it gives me error 773

I just tried using an id to the game you are telporting from and it teleported me to the same game, so I wonder why it still is not working?

Alpha Force - Roblox If you look at the link you will see.

It is working, game.placeId is returning the id of the current place. Try replacing it with the place ID you wanted

I just did, the id from my asset manager is: 10571270983 still not working

It’s working as it should
you just didn’t enabled the access to the place

The logs also tell you that the game isn’t published
(Press F9)

Please note that you also need to do that on the server side since only the server can reserve private servers.

just saw that its different on the browser. 10397756752

It says it public?
Its also a server script.

This is the game its teleporting to Game - Roblox

Is roblox just lagging the publishing or something?

Does anybody else have this problem?


i have this same error Im so annoyed now

i have this error when i use insert service to import meshes.

me too
i’m annoyed too
someone help us!

im sorry mate there is no fix.
how i fix is is by waiting for like 4 days