Keyframes not appearing in animation editor

  1. What is the issue? when animating for a showcase i was making, i noticed that the animation editor didn’t display keyframes, or add parts to the editor altogether.

  2. What solutions have you tried so far?

  • reinstalling didn’t work
  • importing animations worked, but you can’t add other parts

NOTES: re-rigging doesn’t work, it is a genuine ROBLOX model from the rig creator.

Note the absence of keyframes. positioning is saved however.

This is an imported animation. the “add all” button highlighted doesn’t work.

Note 2: the editing of position and rotation is saved in the graph editor, but is not even recognized in the keyframe editor.

any and all help is appreciated. this is a major setback for me and maybe others.
Thank you!

1 Like

experiencing this problem aswell, have tried almost everything to fix it and no results either

Same is happening to me, I hope ROBLOX does something about it!

I don’t want to be that person, but this is also happening to me.

Some interesting side effects I’ve noticed is that…

  • Sometimes, you can’t select the torso or head, but the limbs are okay.
  • You can’t add keypoints manually, even if you tried hard enough.
  • The rotation and move tool can be deselected when you enter the editor.
  • Selecting the “Head” keypoint doesn’t actually select the keypoint, making animating the head a pain.
  • Copy pasting frames do work, however it applies to all of the frames instead of the ones you want.

This is really troublesome for me and other animators. I don’t want to try to learn Moon Animator just because of Roblox not optimizing this. Although this is new, I’d like for this to be fixed. Thank you!

1 Like

Oh! It seems like I’ve found the solution for this.

Upon selecting the rig, you tend to notice the first thing that has changed.


Hmmm… that doesn’t look right. What’s causing this?


Apparently, all of the rigs have defaulted to the Head for their PrimaryPart, even the old ones. That’s very strange. Let’s fix that!

Simply by clicking the PrimaryPart tab, go under your rig and select HumanoidRootPart.


There we go.


Much better!

And hey, I can select my other keyframes… AND the head! Seems like this is a temporary fix for the time being until Roblox restores the default PrimaryPart to the HumanoidRootPart for the time being. Make sure to apply this for all of your rigs, because Roblox did an oopsies.

Hope this helps!


This is a godsend, thank you so much!


If anyone’s too lazy to fix every single rig that they have manually, then check out my plugin

Just select all the rigs and press on the plugin

1 Like

I have the same issue. Setting the PrimaryPart to the HumanoidRootPart worked as a fix.

1 Like

I love you bro, thx a lot :pray::pray::pray:
thought my roblox is cooked

1 Like

Thanks bro, this worked for me :muscle:

1 Like

from the bottom of my heart. thank you

ur a life saver man thank you :+1: