Kick message does not show up?

Whenever the player is still loading and gets kicked with a message, the message will not show.



How do i fix this and why does this happen?

Could not reproduce. Could this possibly be in a Team Create session or something else?

I am in a Team Create session, but im playing in a local test server.
This also happens ingame.

Aha. Then you didn’t save the script/publish the session!

Just make sure you publish the game for testing through those methods.

Hit Alt+P to publish.

The game is already published and the error shows up both ingame and studio.

Try to add a .CharacterAdded to your script and see if it works.

That did not work sadly.
I have also removed every single script in my place and tried testing it with only 1 script with that code.
The message still did not show.

No add a nested function that says Player.CharacterAdded:Connect() ect ect ect

This is an ongoing problem, if you add a 5 second delay onto the message it should end up working.

I added the wait and the message still did not show up.

Are you sure? I tried kick a player with a kick message and it worked perfectly. Also @rickje139 I am afraid we cannot help you, we have no clue what may be causing it. You should probably make a post in engine bugs (if it also happens in your game and not just studio).

I remember reading up on on another post if you had a proper functional game rather than just a baseplate it would not show up.

Very odd.

1 Like

Other then waiting for a substantial amount of time(eg 5-15 seconds), I don’t think there’s a way to fix this unless roblox does something. I’ve had this problem for months and only adding a long wait before kicking would solve it.